images don't wrap in fixed-width tables

RESOLVED WONTFIX

Status

()

Core
Layout: Tables
RESOLVED WONTFIX
16 years ago
16 years ago

People

(Reporter: johann.petrak@gmail.com, Assigned: karnaze (gone))

Tracking

({testcase})

Trunk
mozilla1.1alpha
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
using build 2001112021/linux: the specified url gets rendered as a 
completely blank (white) page.

Comment 1

16 years ago
wfm using build 2001112703 on Win2k.

You have to scroll right to actually see content. I guess this is a dupe of some
other bug dealing with table alignment problem.

Comment 2

16 years ago
wfm also, may be it's the problem of the web page itself ?
Removing the cols attributes from the tables help.

This seems to be a legacy page though generated with NS 4.75.  We shouldn't
render it that badly in quirks mode.  Sending to layout for now, but this site
probably should be evangelised too.
Assignee: asa → attinasi
Component: Browser-General → Layout
QA Contact: doronr → petersen
Created attachment 59531 [details]
Copy of the webpage with an added <base> tag
Status: UNCONFIRMED → NEW
Ever confirmed: true
Only renders a couple of images using 2002012203 build on WINXP. Setting OS to All.
OS: Linux → All
Target Milestone: --- → mozilla1.1
I have the same problem with this page:

   http://www.elcato.org/hanke_argviolaleyes.htm

The page is almost completely blank. But it displays fine on MSIE or NNav4.x
Is this the same bug ?

BuilID 2002022003 on WinNT 4.0

Comment 7

16 years ago
404 anyone saved a full copy ?

Comment 8

16 years ago
the problem with attached copy of the page appears to be that the left column of
the 2nd row is a bunch of <img><a><img></a><img><a><img></a><img>...

Mozilla does not wrap the images even though the table and column width were
specified (it expands the widths beyond their specified values).  NS4 wraps the
images.

Comment 9

16 years ago
Created attachment 102732 [details]
testcase

Mozilla does not wrap the images
NS4 wraps them

Updated

16 years ago
Keywords: testcase

Comment 10

16 years ago
Created attachment 102733 [details]
another testcase

if you specify the width of the column, it works.  if you specify the width of
the same column in a previous row (which is what the originaly did), it doesn't
work.

Comment 11

16 years ago
see also bug 97619

==> Tables
Assignee: attinasi → karnaze
Component: Layout → HTMLTables
QA Contact: petersen → amar
Summary: page gets rendered completely blank → images don't wrap in fixed-width tables

Comment 12

16 years ago
should we wontfix ?

pls refer to bug #54565 #32191 etc. and nsLineLayout.cpp:1932
pls notice that u can reproduce the bug on IE :) 

such behavior is *not* standard compliant while many pages would look bad if it is. 

Comment 13

16 years ago
should we wontfix ?

pls refer to bug #54565 #32191 etc. and nsLineLayout.cpp:1932
pls notice that u can reproduce the bug on IE :) 

such behavior is *not* standard compliant while many pages would look bad if it is. 

Comment 14

16 years ago
if no objection, i will close the bug.

Comment 15

16 years ago
 reopen it if any doubt
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.