Closed Bug 1123599 Opened 5 years ago Closed 5 years ago

[Edge gesture] Scrolling still works when switching between apps

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

x86
macOS
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

VERIFIED FIXED
blocking-b2g 2.2+
Tracking Status
b2g-v2.1 --- unaffected
b2g-v2.2 --- verified
b2g-master --- verified

People

(Reporter: apastor, Assigned: kats)

References

Details

(Keywords: regression, Whiteboard: [systemsfe])

STR:

1.- Open Settings
2.- Open the browser and go to any scrollable page
3.- Start an edge gesture to switch to Settings
4.- Scroll vertically while switching

Expected:

The card is a non scrollable screenshot

Actual

You can actually scroll in the browser, which makes the rocketbar interact and duplicate the statusbar
Asking for regression window
Summary: [Edge gesture] Scrolling still works when in card's view → [Edge gesture] Scrolling still works when switching between apps
Leaving keywords while working on regression window

Issue DOES occur in Flame 2.2, and 3.0

User can scroll card when switching between apps using edge gestures

Device: Flame 2.2
BuildID: 20150120141459
Gaia: b9da64ae4e704476b69102b874f1282ed2fd9598
Gecko: 402e876af74c
Version: 37.0a2 (2.2)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device:  Flame 3.0 Master
BuildID: 20150120032136
Gaia: 579e01ad4d6e4177a8f636305ac877835d99f134
Gecko: c2df1daf74c3
Version: 38.0a1 (3.0)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0


Issue does NOT occur in Flame 2.1

User cannot scroll card during edge gesture

Device: Flame 2.1
BuildID: 20150120131300
Gaia: 77c57eb8a985d5cbd34a597fb1b978ba6e205af6
Gecko: 78c600a5f2fa
Version: 34.0 (2.1)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regression
QA Contact: bzumwalt
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
B2G-Inbound Gecko Regression Window:

Last working gecko b2g-inbound build:
Device: Flame 2.2
BuildID: 20150110075932
Gaia: e8dd840986fd76f27caafa91ac47b96dabb5d082
Gecko: affad3660b5e
Version: 37.0a1 (2.2)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


First broken gecko b2g-inbound build:
Device:  Flame 2.2
BuildID: 20150110105532
Gaia: e8dd840986fd76f27caafa91ac47b96dabb5d082
Gecko: 8cae7aeb3a74
Version: 37.0a1 (2.2)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0


Working Gaia with Broken Gecko issue DOES occur:
Gaia: e8dd840986fd76f27caafa91ac47b96dabb5d082
Gecko: 8cae7aeb3a74

Working Gecko with Broken Gaia issue does NOT occur:
Gaia: e8dd840986fd76f27caafa91ac47b96dabb5d082
Gecko: affad3660b5e


Gecko B2G-Inbound Pushlog: 
http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=affad3660b5e&tochange=8cae7aeb3a74

Issue appears to be due to bug 920036
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Kartikaya, can you take a look at this please? Looks like the work done for bug 920036 may be the culprit here.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(bugmail.mozilla)
Yup. This will be fixed by the combination of bug 1116586 and bug 1116588. Assigning this to myself for now as I'm working on those bugs (one just landed, the other needs a new patch).
Assignee: nobody → bugmail.mozilla
Depends on: 1116586, 1116588
Flags: needinfo?(bugmail.mozilla)
blocking-b2g: --- → 2.2?
definitely a blocker. regression and performance degradation
blocking-b2g: 2.2? → 2.2+
both dependencies landed. Lets test with the next build that includes both patches.
Keywords: verifyme
Note that the fix for bug 1116588 was backed out and a different fix was landed yesterday. I'm marking this bug closed since the new fix is now merged to m-c, because I believe the verifyme keyword is not looked at by QA on bugs that are still open.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
This issue is verified fixed on Flame 2.2 and Master.

Result: The browser cannot be scrolled during the edge gesture.
 
Device: Flame 2.2 (319mb, full flash)
Build ID: 20150202002507
Gaia: d6141fa3208f224393269e17c39d1fe53b7e6a05
Gecko: be206fa2fb60
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame Master (319mb, full flash)
Build ID: 20150202010229
Gaia: 740c7c2330d08eb9298597e0455f53d4619bbc1a
Gecko: 940118b1adcd
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: verifyme
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.