Closed Bug 1123621 Opened 7 years ago Closed 5 years ago

Have more accurate informations about build names, partners and version informations

Categories

(Firefox OS Graveyard :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: clement.lefevre, Unassigned)

References

Details

(Keywords: feature, foxfood)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150108202552

Steps to reproduce:

I tried to get some informations about the versions I am running on.


Actual results:

If you have a phone distributed by a partner with partners builds, I could notice that Gaia revision (commit date and number), Build ID or informations about firmware does not represent real informations given by Mozilla and so you can not say for sure which version is it when you notice a bug.


Expected results:

It would be helpful for bug reporting and so on to have a new build type (we currently have user, userdebug or eng) which would be partner type.
This one would have a specific name so that we could recognize it (getprop ro.build.display.id field ?)
And Mozilla's original build informations (before "giving" the build to partner so that they work on it) would be preserved as an addition to partner's informations.

This to help to know everything about the software part installed on the phone, either from Mozilla's original build or from partner's build, which are basically Mozilla's one plus a couple of modifications from their part.
This is going to be tricky. Partners have their own repos and they sometimes cherry-pick commits from Mozilla. Even with knowing the last revision from Mozilla, it'll be hard to know if they didn't cherry-pick some other commits on the way.

Another issue is that we can't create a "partner build" as they need the source code to make their own modification.

It seems like we need another way of knowing what comes from Mozilla and doesn't.
Keywords: feature, foxfood
See Also: → 1180678
Isn't this a duplicate of bug 834462?

I don't have the privileges to mark as duplicate. Or I just can't find the mark as duplicate button.
(In reply to Shine Nelson [:shine] from comment #2)
> Isn't this a duplicate of bug 834462?
> 
> I don't have the privileges to mark as duplicate. Or I just can't find the
> mark as duplicate button.

I don't feel like this is a duplicate, as the bug you pointed out is about having release notes/changelog when a new release is out and you update with OTA.

What I'm talking about here is that for partner devices (Let's say, ZTE Open C, for example), it is not possible for user to give useful informations, because commit dates are those from ZTE.

You should be able to see which Mozilla build was used to start with (so that we know the state of what Mozilla did and what was the clean Gonk/Gecko/Gaia at that time) and then what the partner did with its own versions, commit ID and so on.

So build type: partner and then store informations about Mozilla's build and partner changes (patches and so on)
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.