dissrc does not work

RESOLVED FIXED in mozilla38

Status

()

Core
JavaScript Engine
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: tromey, Assigned: tromey)

Tracking

Trunk
mozilla38
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
I tried the "dissrc" function, using a "js" built from a recent
hg tree.  It did not do anything:

pokyo. cat /tmp/r.js
function f() { }
pokyo. ./obj-x86_64-unknown-linux-gnu/dist/bin/js
js> load("/tmp/r.js")
js> dissrc(f)
js> 


The problem is that dissrc creates a Sprinter but then
discards the results collected there.

I'll attach a patch shortly.
(Assignee)

Updated

4 years ago
Assignee: nobody → ttromey
(Assignee)

Comment 1

4 years ago
Created attachment 8551769 [details] [diff] [review]
change dissrc to print result
(Assignee)

Updated

4 years ago
Attachment #8551769 - Flags: review?(jdemooij)
Comment on attachment 8551769 [details] [diff] [review]
change dissrc to print result

Review of attachment 8551769 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, thanks.
Attachment #8551769 - Flags: review?(jdemooij) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/e709973a9049
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
You need to log in before you can comment on or make changes to this bug.