Characters wrongly inserted when forwarding



Message Compose Window
3 years ago
3 years ago


(Reporter: Peter Ashford, Unassigned)


31 Branch
Windows XP

Firefox Tracking Flags

(Not tracked)



(1 attachment)

15.07 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document


3 years ago
Created attachment 8551791 [details]
Sample of text garbled by Thunderbird (pasted into Word)

User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/39.0.2171.99 Safari/537.36

Steps to reproduce:

Regular situation, current TB 31.4.0.  Receiving a reply to a sent message or re- sending a sent message opening as 'edit as new'.

Actual results:

A letter 'A' character with a circumflex accent becomes inserted throughout the message text where the initial text has spaces or an apostrophe.

Repeated re-sending etc adds other spurious characters as in attached file.

Expected results:

one or more repeated use of emailed message texts should leave it unchanged with no inserted characters.

Comment 1

3 years ago
Does it happen with thunderbird in safe mode?

If it does, please save original message as .eml file with File | Save As, and attach to this bug report
Flags: needinfo?(peter.ashford)


3 years ago
Component: Untriaged → Message Compose Window
Whiteboard: [closeme 2015-02-15]

Comment 2

3 years ago
Resolved per whiteboard
Last Resolved: 3 years ago
Flags: needinfo?(peter.ashford)
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2015-02-15]

Comment 3

3 years ago
Since reporting (after experiencing several instances of the problem) I have had no further occurrences and I have been unable to create the problem.  Sorry

Comment 4

3 years ago
Thanks for the update

Comment 5

3 years ago
I've just now found the cause of the problem after opening a previously-sent email to forward it to someone else.

The extra characters get inserted if you make more than one space between words or at the end of one sentence before starting the next.  I just sent the following test message to myself (its the same if you send it to someone else).  Re-opening the Sent message either to forward it or to edit as new shows a Character " Â " in the surplus spaces.  This next following is my test message with its description of the deliberate spaces and how the Sent message appears when you re-open it.

Here is a test message below with (a) two spaces between the first two words, (b) three spaces between the second and 3rd word, and (c) two spaces after the period at the end of the first sentence:

This is  sentence   number 1.  This is sentence 2.
You need to log in before you can comment on or make changes to this bug.