Closed Bug 1123705 Opened 7 years ago Closed 7 years ago

The _getStringHash method used in createFlameGraphDataFromSamples can sometimes return Infinity

Categories

(DevTools :: Performance Tools (Profiler/Timeline), defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 38

People

(Reporter: vporof, Assigned: vporof)

References

Details

Attachments

(1 file, 1 obsolete file)

No description provided.
Summary: Off by one error in createFlameGraphDataFromSamples → The _getStringHash method used in createFlameGraphDataFromSamples can sometimes return Infinity
Attached patch v1 (obsolete) — Splinter Review
Assignee: nobody → vporof
Status: NEW → ASSIGNED
Attachment #8551830 - Flags: review?(jsantell)
Attached patch v1Splinter Review
hg add, victor
Attachment #8551830 - Attachment is obsolete: true
Attachment #8551830 - Flags: review?(jsantell)
Attachment #8551833 - Flags: review?(jsantell)
Comment on attachment 8551833 [details] [diff] [review]
v1

Review of attachment 8551833 [details] [diff] [review]:
-----------------------------------------------------------------

Infinity means really good performance, right?
Attachment #8551833 - Flags: review?(jsantell) → review+
(In reply to Jordan Santell [:jsantell] [@jsantell] from comment #3)
> Comment on attachment 8551833 [details] [diff] [review]
> v1
> 
> Review of attachment 8551833 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Infinity means really good performance, right?

Like.
Duplicate of this bug: 1123942
https://hg.mozilla.org/mozilla-central/rev/428415b79822
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 38
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.