HTML5 video / audio playback won't work with Windows N editions, with no feedback for the user

RESOLVED DUPLICATE of bug 848994

Status

()

RESOLVED DUPLICATE of bug 848994
4 years ago
2 years ago

People

(Reporter: msoulatre, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150120030203

Steps to reproduce:

Using Windows N Edition (that doesn't include H.264 codecs), visit any website with HTML5 content (such as vine.com, archive.org, arkvid.tv etc.).

(tried with both stable and latest nightly Firefox branch)


Actual results:

No music / video playback, no feedback.


Expected results:

A way to tell the user the reason why it's not working.
(note : installing the windows update "Windows Feature Pack" solves the problem)

Updated

4 years ago
Component: Untriaged → Video/Audio
Product: Firefox → Core
The video controls do support showing an error message, and I remember an old bug or two about improving the error message specifically for when H.264 media is unplayable (instead of a generic unsupported-codec message). Is the error event not firing for some reason?

Also, can you provide a specific URL on archive.org that's triggering this for you?
(Reporter)

Comment 2

4 years ago
I see no error message on the player. This will trigger on every media on archive.org that i tried (with the default HTML5 player), example :
https://archive.org/details/riderspurplesage_law_librivox

I do get an error when i try to open one of the (128Kbps) MP3 files listed below, such as
https://ia600400.us.archive.org/22/items/riderspurplesage_law_librivox/purplesage_01_grey.mp3

"Video can't be played because the file is corrupt."

This file plays fine on my install with the Media Feature Pack installed.

Comment 3

4 years ago
Created attachment 8607786 [details]
video.canPlayType example (with media file)

Comment 4

4 years ago
Created attachment 8607788 [details]
Test case (firefox-windows-n-h264) on Windows 7.

Comment 5

4 years ago
Created attachment 8607790 [details]
Test case (firefox-windows-n-h264) on Windows 7 (N Edition).

Comment 6

4 years ago
This is especially tricky for developers because video.canPlayType() returns 'probably' for 'video/mp4' even on Windows N editions where the decoder is not present. Test case attached as attachment 8607786 [details]. If Firefox returned '' from video.canPlayType('video/mp4') on Windows N editions, then developers could detect this situation and use a fallback mechanism to play the file.
Component: Audio/Video → Audio/Video: Playback
This should be fixed by bug 1210231.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1210231
You need to log in before you can comment on or make changes to this bug.