Bugzilla changelog page should link to git instead of bonsai or bzr

RESOLVED FIXED

Status

()

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: justdave, Assigned: gerv)

Tracking

Details

(URL)

Attachments

(1 attachment)

From Damien via the developers mailing list:

> Half the links go to bonsai.mozilla.org while the other half goes to
> bzr.mozilla.org.  If the CVS / BZR imports were all successful, and GIT is the
> source of truth, maybe someone can spend some cycles on fixing the changelog
> page.
Step 1: Need to find out if we can link a range of the changelog in git's web viewer or not.  Perhaps use the github mirror? they have a decent viewer I think.

Updated

4 years ago
Duplicate of this bug: 1124194
(In reply to Damien Nozay [:dnozay] from comment #2)
> e.g. https://github.com/bugzilla/bugzilla/compare/4.2...4.4

Taking that example, I get the warning message:

"This comparison is big! We're only showing the most recent 250 commits"

and there is no "More..." button at the bottom. Do we have any other options which demonstrate the full list of commits?

Or do we think that if there are over 250 commits, no-one is actually going to review them manually anyway, so we should just go ahead, assuming that people will find this more useful for the 4.4.1 -> 4.4.2 style changes?

Gerv

Comment 5

4 years ago
(In reply to Gervase Markham [:gerv] from comment #4)
> Or do we think that if there are over 250 commits, no-one is actually going
> to review them manually anyway, so we should just go ahead, assuming that
> people will find this more useful for the 4.4.1 -> 4.4.2 style changes?

Not being able to view the whole list is definitely a regression. This list is important when tracking regressions.
Yes, I think that first URL is it.

Gerv
Created attachment 8569167 [details] [diff] [review]
Patch v.1

Now everything uses git.

Gerv
Assignee: website → gerv
Status: NEW → ASSIGNED
Attachment #8569167 - Flags: review?(LpSolit)

Comment 9

4 years ago
Comment on attachment 8569167 [details] [diff] [review]
Patch v.1

This looks good, but please bring back the 4.5.6 -> master link. Since we branched for 5.0rc1, the link to master is gone. r=LpSolit
Attachment #8569167 - Flags: review?(LpSolit) → review+
Checking in src/status/changes.html;
/www/bugzilla-org/src/status/changes.html,v  <--  changes.html
new revision: 1.100; previous revision: 1.99
done

Gerv
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.