FlameGraphUtils.createFlameGraphDateFromSamples -> bucket is undefined

RESOLVED DUPLICATE of bug 1123705

Status

()

Firefox
Developer Tools: Performance Tools (Profiler/Timeline)
RESOLVED DUPLICATE of bug 1123705
3 years ago
3 years ago

People

(Reporter: jsantell, Unassigned)

Tracking

37 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

STR
Start recording a profile. Refresh the page. Stop recording the profile. get this following error (e10s and non e10s):

TypeError: bucket is undefined: FlameGraphUtils.createFlameGraphDataFromSamples@resource:///modules/devtools/FlameGraph.jsm:894:11
FlameGraphView.render@chrome://browser/content/devtools/performance/views/details-flamegraph.js:56:19
FlameGraphView._onRecordingStoppedOrSelected@chrome://browser/content/devtools/performance/views/details-flamegraph.js:72:7
EventEmitter_emit@resource://gre/modules/commonjs/toolkit/loader.js -> resource://gre/modules/devtools/event-emitter.js:137:11
PerformanceController.stopRecording<@chrome://browser/content/devtools/performance/performance-controller.js:227:5
TaskImpl_run@resource://gre/modules/Task.jsm:314:40
Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:870:23
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:749:7
this.PromiseWalker.scheduleWalkerLoop/<@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:691:37
Fixed by 1123705
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1123705
You need to log in before you can comment on or make changes to this bug.