Closed Bug 1123948 Opened 5 years ago Closed 5 years ago

Intermittent browser_ruleview_livepreview.js | Element should be previewed as inline - Got block, expected inline

Categories

(DevTools :: Inspector, defect)

x86
Linux
defect
Not set

Tracking

(firefox36 unaffected, firefox37 unaffected, firefox38 fixed, firefox-esr31 unaffected)

RESOLVED FIXED
Firefox 38
Tracking Status
firefox36 --- unaffected
firefox37 --- unaffected
firefox38 --- fixed
firefox-esr31 --- unaffected

People

(Reporter: RyanVM, Assigned: bgrins)

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

06:28:57 INFO - 5163 INFO TEST-PASS | browser/devtools/styleinspector/test/browser_ruleview_livepreview.js | The focused editor is the value
06:28:57 INFO - 5164 INFO Enter a value in the editor
06:28:57 INFO - 5165 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "chrome://mochitests/content/browser/browser/devtools/styleinspector/test/head.js" line: 128}]
06:28:57 INFO - 5166 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "chrome://mochitests/content/browser/browser/devtools/styleinspector/test/head.js" line: 128}]
06:28:57 INFO - 5167 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "chrome://mochitests/content/browser/browser/devtools/styleinspector/test/head.js" line: 128}]
06:28:57 INFO - 5168 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "chrome://mochitests/content/browser/browser/devtools/styleinspector/test/head.js" line: 331}]
06:28:57 INFO - 5169 INFO Console message: [JavaScript Warning: "unsafe CPOW usage" {file: "chrome://mochitests/content/browser/browser/devtools/styleinspector/test/head.js" line: 331}]
06:28:57 INFO - 5170 INFO Sending message Test:GetComputedStylePropertyValue to content
06:28:57 INFO - 5171 INFO Expecting message Test:GetComputedStylePropertyValue from content
06:28:57 INFO - 5172 INFO TEST-UNEXPECTED-FAIL | browser/devtools/styleinspector/test/browser_ruleview_livepreview.js | Element should be previewed as inline - Got block, expected inline
06:28:57 INFO - Stack trace:
06:28:57 INFO - chrome://mochikit/content/browser-test.js:test_is:851
06:28:57 INFO - chrome://mochitests/content/browser/browser/devtools/styleinspector/test/browser_ruleview_livepreview.js:testLivePreviewData:66
06:28:57 INFO - self-hosted:InterpretGeneratorResume:702
06:28:57 INFO - self-hosted:next:610
06:28:57 INFO - Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:870:23
06:28:57 INFO - this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:749:7
06:28:57 INFO - this.PromiseWalker.scheduleWalkerLoop/<@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:691:37
Sorry to keep picking on you, Patrick, but do you have time to look into this? Otherwise, can you please help me find someone who does? It's top-20 on OrangeFactor.
Looks like the culprit isn't too hard to find! See this comment:
http://mxr.mozilla.org/mozilla-central/source/browser/devtools/styleinspector/test/browser_ruleview_livepreview.js#60

So, most likely, the change made in the rule-view hasn't yet been applied to the page by the time we read the value from the computed style.

The problem with solving this is that I don't think there is an event we can subscribe to in order to know when the style has been changed. So other than increasing the timeout (which is bound to keep on failing, on a less regular basis, but still), or polling for the value, I don't know how else to fix this.

Brian: do you see any other option here? Btw, would you have time to look into this? I'm a bit swamped right now. I'm happy to work on it, but it won't be before next week or so, so in case you have some time right now, that'd be great.
Flags: needinfo?(pbrosset) → needinfo?(bgrinstead)
This works locally and should get rid of the orange.  The issue is that there is a modifyproperties request that is pending - the timeout was a workaround for that.  Here is a a try push: https://treeherder.mozilla.org/#/jobs?repo=try&revision=b30499e475e3
Assignee: nobody → bgrinstead
Status: NEW → ASSIGNED
Flags: needinfo?(bgrinstead)
Attachment #8566077 - Flags: review?(pbrosset)
Comment on attachment 8566077 [details] [diff] [review]
applyingModifications.patch

Review of attachment 8566077 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me, let's wait to see if try is green. Make sure yo re-trigger linux e10s dt tests.
Attachment #8566077 - Flags: review?(pbrosset) → review+
That last try push was bad, here is a new one: https://treeherder.mozilla.org/#/jobs?repo=try&revision=1aabf95f130f.
Keywords: checkin-needed
https://hg.mozilla.org/integration/fx-team/rev/dbe38ec9c16d
Flags: in-testsuite+
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/dbe38ec9c16d
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 38
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.