Plugins not being recognised

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: m1scha_m, Assigned: serhunt)

Tracking

Trunk
x86
Windows ME
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:0.9.6+) Gecko/20011127
BuildID:    2001112703

the plugins are not being recognised by sites. I presume this is similar to the
nightly 2001112303 I have just replaced where the option to delete individual
cookie sites was left out of the build. What is happening, are the wheels
beginning to fall off or something

Reproducible: Always
Steps to Reproduce:
1.Any site that needs a plugin, doesn't matter what it is
2.
3.

Actual Results:  Asked to download plugin

Expected Results:  plugin should be recognised

is it becoming necessary to put some reference to a plugin into the plugin
folder, which is what I do with Java each time I install a nightly rebuild?
(Reporter)

Comment 1

17 years ago
What is wrong with this version. The status bar keeps vanishing, some sites do
not sing me in correctly, and others do not bring up the preferred settings I
have made. Is this an attempt to make some form of alteration to Mozilla, if so
I am not impressed.
(Reporter)

Comment 2

17 years ago
Plugins still not being recognised in build 2001112803.
(Assignee)

Comment 3

17 years ago
Reporter, what plugin dlls do you actually have in your Mozilla plugins folder?
(Reporter)

Comment 4

17 years ago
Adobe Acrobat Reader
Macromedia Flash Player
Shockwave
Real Player
Java
(Assignee)

Comment 5

17 years ago
OK. 

1. What does about:plugins report?
2. Do you have 4x installation? 
   If you do...
3. Try to rename 4x plugins folder and restart Mozilla.
(Reporter)

Comment 6

17 years ago
I have checked the plugins installed on my computer with the Netscape plugins
page using NS4.79, it shows I have:-
Sun Java;
Adobe Acrobat;
Macromedia Flash 5;
RealNetworks RealPlayer;
Shockwave 8.5;
Microsoft DRM;
Microsoft Windows Media Player;
Windows Media Player dll;
Netscape Live Audio;
NPAV132.dll;
Netscape default.
As you can see not all of these are in the Netscape plugins folder, so if the
Netscape plugins page can identify these, why can't Mozilla when it could before
I loaded Build 2001112703. Should I also rename my Microsoft folders as well?
In addition I upgraded from Build 2001112803 to Build 2001112903.
(Assignee)

Comment 7

17 years ago
The idea is this: Mozilla uses plugins from both its own and 4x plugins folders. 
Some caching plugins info mechanism has been implemented recently, and it is 
known to cause problems which may look like you described here. The problem 
occurs when at least one of the plugins (in either folder) uses special chars 
in its name and description strings (like MS DRM plugin does). Removing the 
problematic plugin should fix the problem. That's why I asked to remove (rename 
for that matter the whole 4x plugins folder to see if this is it. This problem 
should be fixed in past Nov.27 builds.

So, looks like you have only Java and the default plugin in the Mozilla folder, 
right? What does about:plugins in Mozilla say? And does removing 4x plugins 
folder help?
(Reporter)

Comment 8

17 years ago
when I rename the NS4.79 Plugins folder, the Netscape plugins page says I have
only Java, and Mozilla Default plugins installed. When the folder is restored
the Netscape plugins page says there are no plugins installed.
(Assignee)

Comment 9

17 years ago
That's what I thought. Can you please now do the following?
1. Rename 4.x Plugins folder
2. Create an empty 4.x Plugins folder
3. Copy np*.dll's (other files are not necessary for this experiment) from the 
renamed folder to the newly created empty folder one by one, rechecking 
Mozilla's about:plugins every time after you copy a new dll.
4. When it stops working, this is the one which causes the problem.
(Reporter)

Comment 10

17 years ago
Sorry about not getting back to you sooner, I have been in the field.
Before doing what you requested I downloaded and installed nightly build
2001120603 which may have fixed the problem because when I began filling the new
plugins folder each and every .dll was recognised correctly. So where does that
leave this bug?

Comment 11

17 years ago
wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 12

17 years ago
Verifying.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.