GDC 2015: Booth Staff T-Shirts

RESOLVED FIXED

Status

Marketing
Design
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Robyn Chau, Assigned: Sean Martell)

Tracking

(Blocks: 1 bug)

Details

(Reporter)

Description

3 years ago
>>Project/Request Title:
GDC 2015: Booth Staff T-Shirts

>>Project Overview:
GDC is annually the authoritative game developer/creator/producer industry event. This is a critical stage for Mozilla to be showcasing our achievements and reaching developers and partners. 

For more details, please refer to the Creative Brief: http://bit.ly/156Uy4E 

>> Creative Help Needed:
Copy:    Yes 
Design:  Yes 
Video:   No 
Other:  No

>>Creative Specs:
- Illustrator file ready for printing by vendor
- JPG of design for vendor's visual reference



>>CTA and Design:
Mozilla's presence this year at GDC is a very exciting one - partners are shipping with our tools, we are delivering game-changing technology, and we are stepping forward as pioneers and innovators. Our on-site staff need shirts that are representative of this, and that are relatable and relevant to the games industry. 

Some suggestions/requests from the team:
- style similar to the OdinMonkey shirt (artist: John Howard, monkeyink.com)
- a riff off of the phrasing "Achievement Unlocked" (a well-known phrase for when you reach the next level in a video game)
- a design that is inspired by today's popular games (Halo, The Last of Us), which is frequently more lifelike, and has a streamlined aesthetic, or that is inspired by popular indie games that have a very widely ranging aesthetic (Super Meat Boy, Republique, No Man's Sky, Braid)
- a design that asserts achievement, pride
- could hearken to futuristic fantasy storylines like Tron

Art of Halo: http://yhoo.it/1CNuGGs
Art of The Last of Us: http://yhoo.it/1CNuMxU
Celebrated indie game art samples: http://on.mash.to/1CNuDdL 

Creative Brief: http://bit.ly/156Uy4E 
Mozilla Booth Design: http://bit.ly/1Gsddtf 

Usable shirt areas: front, back, left and right sleeves.

>>Creative Due Date:
2015-02-04

>>Launch Date:
2015-03-02

>>Mozilla Goal:
Firefox Browser

>>Mozilla Creative Collective:
No

>>Points of Contact:
sprasad@mozilla.com,
(Reporter)

Comment 1

3 years ago
Note: We have been collaborating with Sean Martell and Barry Munsterteiger on the design of our show floor booth, in case collaboration here on shirt design is to be tied to the feel/aesthetic of the booth.

Comment 2

3 years ago
Hi Robyn,

Thanks for filing. Looking at the booth design, I notice that it says both "Be the future" and "Blaze your own path," but only "Be the future" should be used with that outline version of the fox. Is that still being updated?
(Reporter)

Comment 3

3 years ago
Hi Matej,

Those are placeholders - I'm mid-filing for those aspects of the booth :)  We will be leading with Firefox, and Firefox OS will be a small portion of our presence at the show, so it's likely we should remove the BtF and BYOP copy from the booth and any ideas for the t-shirts.

Hope that helps!

Comment 4

3 years ago
(In reply to Robyn Chau from comment #3)
> Hi Matej,
> 
> Those are placeholders - I'm mid-filing for those aspects of the booth :) 
> We will be leading with Firefox, and Firefox OS will be a small portion of
> our presence at the show, so it's likely we should remove the BtF and BYOP
> copy from the booth and any ideas for the t-shirts.
> 
> Hope that helps!

That's perfect. Thanks for the clarification.

Comment 5

3 years ago
Hi Robyn, 

Shez had requested the new Developer logo t-shirts (design in bug 1085587) for GDC. I'm not sure if this was to be used as a staff shirt or for giveaways. The focus might have also changed where this is no longer relevant. 

Just wanted to make a note on this.
(Reporter)

Comment 6

3 years ago
Hi Jen,

I believe these are for giveaways, not staff shirts. Thanks for the reminder though :)

Comment 7

3 years ago
Ah. Ok. Don't forget that those shirts also still need to be ordered. :)
(Reporter)

Comment 8

3 years ago
You bet! Thanks :)

Comment 9

3 years ago
Handing this one off to Ty.

I think there may be a visual solution that doesn't require copy and still achieves the desired effect, but Ty and I will brainstorm a few ideas and share them soon.
Assignee: jbalaco → tflanagan

Updated

3 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 10

3 years ago
CCing Sandra Persing; we've had some chats about potential designs - Sandra feel free to jump in here :)
(Reporter)

Updated

3 years ago
Blocks: 1107589
Update: Sean is working on the booth in bug 1124341 and the design is going to carry over into the shirts, so I'm assigning this one over to him instead.
(Assignee)

Updated

3 years ago
Assignee: tflanagan → smartell
(Assignee)

Comment 12

3 years ago
Hey all,

Here's the overall look for the GDC creative:
http://cl.ly/image/0p1W3F1x2R3k

Wanted to make the tshirt an extension of the booth artwork - a takeaway of the style.

Let me know your thoughts.

Enjoy!
(Reporter)

Comment 13

3 years ago
Thanks Sean. The cl.ly link is showing no files are there, can you repost please?
Flags: needinfo?(smartell)
(Reporter)

Comment 14

3 years ago
Cancel that, Sean - the link's working now!

Hi Barry, Martin, Bertrand - could you please take a look at the link in Comment 12 and provide feedback today? Thanks!
Flags: needinfo?(smartell)
Flags: needinfo?(mbest)
Flags: needinfo?(bneveux)
Flags: needinfo?(barry)
So similar comments than before.  I love the art work, love the concept.  Seems like the details are there.  Going to be proud to be there.

t-shirt flame looks a bit flat, the yellow and pink are not working for me.

Close but I don't think this is there yet.

Martin
Flags: needinfo?(mbest)
(Assignee)

Comment 16

3 years ago
Martin - I'd prefer to stick with the colors here if possible. The panels are using our new bolder Mozilla colors and I feel this is a great venue to use the expanded palette - not just blue/orange.

Could you expand on why they're not working for you?

Also - it's bikeshed magenta, not pink. ;)

Background to the shapes - sword and shield, both coming from game project branding I previously created at Mozilla.

Gladius:
http://blog.seanmartell.com/wp-content/uploads/2012/03/logo_0062_63.png

Paladin:
http://blog.seanmartell.com/wp-content/uploads/2012/03/logo_0061_62.png
Hey, sorry, I'm apparently alone in my comments.  I ran this by a few people on the team and everyone loved it.

Apparently I'm a yellow and magenta hater and should keep that kind of thing to myself.

The one question I did get was about the demo panels, would they stay the darker blue?

Martin
Do we have an issue with the Dino being in there?
(Assignee)

Comment 19

3 years ago
Hey hey,

I think using the lighter blue for the outside panels works, yes, to match the light blue panel on the pillar. This is a departure from the "dev theme" but it's a tease of our new bolder color/style.

As for the dino - we're not selling the gear, so we're good! loopholes! :)
(Assignee)

Comment 20

3 years ago
Hey all,

Final tshirt artwork for GDC 2015 can be found here:
http://people.mozilla.org/~smartell/GDC/2015/mozilla-gdc2015_tshirt-royal-blue_CMYK.eps

Preview JPG here:
http://people.mozilla.org/~smartell/GDC/2015/mozilla-gdc2015_tshirt-royal-blue.jpg

Enjoy!!

Comment 21

3 years ago
Hi Sean, Please include: https://games.mozilla.org 
on the t shirt
The link is not yet live (around Feb 25th or so), but confirmed as official for our swag.

Thanks
Sandra
Flags: needinfo?(smartell)
(Assignee)

Comment 22

3 years ago
What is going to be on that site? Will it be the GDC landing page?

I ask because there is nothing there and I haven't seen any designs other than the event landing page.
Flags: needinfo?(smartell)
Another couple of points of clarification:

Are these T-shirts for the booth staff to wear, as it says in the name of the bug, or for a giveaway?

And if for a giveaway, will something always be at the URL for people to go to?
Flags: needinfo?(spersing)

Comment 24

3 years ago
URL - yes, GDC Landing page. I believe so, for as long as URL's live...
T-shirts - yes, 2K will be printed for both booth wear and swag
Thanks
Flags: needinfo?(spersing)

Comment 25

3 years ago
Another clarification: T shirt design needs to be submitted by Feb 6th to be printed and delivered on time. Thank you
(Assignee)

Comment 26

3 years ago
Hey all,

Went with URL on back and Firefox wordmark on the sleeve.
http://cl.ly/image/0f2Y3D3D1Z05

Once we get an ok, I'll upload the vendor-ready file for printing. Approved by our creative team, just need approval from GDC crew.

Thanks!

Comment 27

3 years ago
Sean, the URL on the back looks great - can we still keep the Firefox logo on the sleeve (instead of the wordmark only). Thank you.
Flags: needinfo?(smartell)
(Assignee)

Comment 28

3 years ago
I'd prefer we didn't actually. We only ever put wordmarks on the sleeves of tshirts.

If everything else is fine, I'll upload the final artwork.
Flags: needinfo?(smartell)
(Assignee)

Comment 29

3 years ago
Final tshirt artwork for GDC 2015 can be found at same link here:
http://people.mozilla.org/~smartell/GDC/2015/mozilla-gdc2015_tshirt-royal-blue_CMYK.eps

Enjoy!
(Assignee)

Comment 30

3 years ago
Final link above still applies, but I've added the Firefox logo to the other sleeve:
http://cl.ly/image/373K3c0k0L3c

For print: http://people.mozilla.org/~smartell/GDC/2015/mozilla-gdc2015_tshirt-royal-blue_CMYK.eps

I'm not putting it on the back as the logo + URL stack isn't a great look.

This isn't a solution I'm overly comfortable with, but given it is deadline day and these URL + logo requirements are last minute additions, we can go with this.

Thanks all!

Updated

3 years ago
Flags: needinfo?(barry)
Gonna paint my face and yell this while wearing such shirt at GDC. [0]

[0] http://cdn.meme.am/instances/54795924.jpg

Comment 32

3 years ago
Going to resolve this bug, since hopefully these are already with the vendor.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Updated

3 years ago
Flags: needinfo?(bneveux)
You need to log in before you can comment on or make changes to this bug.