Firefox dev tools sometimes loses pseudo styling

RESOLVED WORKSFORME

Status

P3
normal
RESOLVED WORKSFORME
4 years ago
4 months ago

People

(Reporter: ian, Unassigned)

Tracking

35 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [btpp-backlog])

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150108202552

Steps to reproduce:

I was attempting to debug :before and :after pseudo styles on a div. The dev tools produce a ::before and ::after element which allows you to click on it and view and perhaps edit the appropriate stles, just like other elements.


Actual results:

Sometimes (not always) the styles disappear and can no longer be viewed or edited via the dev tools. Only closing and re-opening the dev tools (via F12) will allow them to reappear.


Expected results:

The styles should not disappear!

Updated

4 years ago
Component: Untriaged → Developer Tools: Inspector

Comment 1

3 years ago
I am seeing this behavior as well for ::before/:before pseudo elements created in the right-hand CSS Rules pane. When I add an ::before elemement, I can see the rendered content in the browser but no node in the Inspector. 

When I inspect another node in the inspector and then go back and select the node I added the rule to, the new ::before rule is gone. The rendered content is still on the screen, but the node is still not present in the Inspector and the CSS rule on the right is gone. Closing and reopening dev tools doesn't have any affect.

Comment 2

3 years ago
Also, I am on FF 42.0 on Mac OSX 10.10.5

Comment 3

3 years ago
Sorry, I was mistaken. I am now seeing it after closing and reopening the Dev tools I apologize for the spam.
I can't reproduce the symptoms described by Daniel on FF45. When I create a new ::before or ::after pseudo element from the rule view it is immediately visible in the markup view.

Ian: do you still experience the original issue and if yes, do you have better STRs we could use? Thanks!

Inspector bug triage. Filter on CLIMBING SHOES. (temporarily triaging as P3, will reevaluate if confirmed)
Flags: needinfo?(ian)
Priority: -- → P3
Whiteboard: [btpp-backlog]
(Reporter)

Comment 5

2 years ago
Sorry for the extremely late reply, but I wasn't aware anything had been posted.

I haven't seen this issue in a while to be honest, but I equally haven't been heavily testing pseudo elements which caused me to come across the issue in the first place.

Comment 6

11 months ago
Let's close for now and re-open if the problem comes back again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → WORKSFORME
Flags: needinfo?(ian)

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.