Closed Bug 1124143 Opened 7 years ago Closed 7 years ago

Animated pictures only plays the first few frames then stop

Categories

(Core :: ImageLib, defect)

37 Branch
x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1119938

People

(Reporter: kemenaran, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150120004008

Steps to reproduce:

I have issues with animated content (animated GIF mainly, although I suspect animated SVG or PNG is affected as well). The animation starts playing, but stops after a few frames.

This is visible on animated spinners, and even on the "Loading…" animation in every Firefox tab.

Steps to reproduce:

1. Load http://pixgood.com/animated-spinner-png.html
2. Observes that some images are randomly not animated (while they are animated in other browsers)

The problem is not 100% reproductible though. It seems related to cache-status or browser state.
NB: this is a regression from Firefox 36.0a2.
I expect that this is a duplicate of bug 1119938, which is fixed on 38 but is still waiting to be uplifted to 37.
Blocks: 1079627
Component: Untriaged → ImageLib
Product: Firefox → Core
Indeed I can't reproduce this issue on Nightly.
Yep, agreed that this is a dupe of bug 1119938. Sorry you're hitting this! I'll uplift the fix as soon as I can. (There is still another bug that has to be fixed first.)
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1119938
You need to log in before you can comment on or make changes to this bug.