Closed Bug 1124188 Opened 5 years ago Closed 5 years ago

crash in java.lang.NullPointerException interface method ''int android.database.Cursor.getCount()'' on a null object reference at org.mozilla.gecko.home.TopSitesPanel$CursorLoaderCallbacks.onLoadFinishedAfterTransitions(TopSitesPanel.java)

Categories

(Firefox for Android :: Profile Handling, defect, critical)

All
Android
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1123688
Tracking Status
firefox37 --- unaffected
firefox38 --- affected
fennec 38+ ---

People

(Reporter: snorp, Assigned: rnewman)

References

Details

(Keywords: crash, regression, reproducible)

Crash Data

This bug was filed from the Socorro interface and is 
report bp-006be27b-5ec2-48a9-89bc-336cf2150121.
=============================================================

I've hit this on nightly several times by clicking the url bar on the awesome screen I believe.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1123688
Not entirely sure actually if that's the same (probably?)

E/GeckoCrashHandler( 4946): java.lang.NullPointerException: Attempt to invoke interface method 'int android.database.Cursor.getCount()' on a null object reference
E/GeckoCrashHandler( 4946): 	at org.mozilla.gecko.home.TopSitesPanel$CursorLoaderCallbacks.onLoadFinishedAfterTransitions(TopSitesPanel.java:721)
E/GeckoCrashHandler( 4946): 	at org.mozilla.gecko.home.TransitionAwareCursorLoaderCallbacks$OnLoadFinishedRunnable.run(TransitionAwareCursorLoaderCallbacks.java:53)
E/GeckoCrashHandler( 4946): 	at org.mozilla.gecko.animation.TransitionsTracker.runAfterTransitions(TransitionsTracker.java:114)
E/GeckoCrashHandler( 4946): 	at org.mozilla.gecko.home.TransitionAwareCursorLoaderCallbacks.onLoadFinished(TransitionAwareCursorLoaderCallbacks.java:19)
E/GeckoCrashHandler( 4946): 	at android.support.v4.app.LoaderManagerImpl$LoaderInfo.callOnLoadFinished(Unknown Source)
E/GeckoCrashHandler( 4946): 	at android.support.v4.app.LoaderManagerImpl$LoaderInfo.onLoadComplete(Unknown Source)
E/GeckoCrashHandler( 4946): 	at android.support.v4.content.Loader.deliverResult(Unknown Source)
E/GeckoCrashHandler( 4946): 	at org.mozilla.gecko.home.SimpleCursorLoader.deliverResult(SimpleCursorLoader.java:71)
E/GeckoCrashHandler( 4946): 	at org.mozilla.gecko.home.SimpleCursorLoader.deliverResult(SimpleCursorLoader.java:26)
E/GeckoCrashHandler( 4946): 	at android.support.v4.content.AsyncTaskLoader$LoadTask.onPostExecute(Unknown Source)
E/GeckoCrashHandler( 4946): 	at android.support.v4.content.ModernAsyncTask.access$500(Unknown Source)
E/GeckoCrashHandler( 4946): 	at android.support.v4.content.ModernAsyncTask$InternalHandler.handleMessage(Unknown Source)
E/GeckoCrashHandler( 4946): 	at android.os.Handler.dispatchMessage(Handler.java:102)
E/GeckoCrashHandler( 4946): 	at android.os.Looper.loop(Looper.java:135)
E/GeckoCrashHandler( 4946): 	at android.app.ActivityThread.main(ActivityThread.java:5221)
E/GeckoCrashHandler( 4946): 	at java.lang.reflect.Method.invoke(Native Method)
E/GeckoCrashHandler( 4946): 	at java.lang.reflect.Method.invoke(Method.java:372)
E/GeckoCrashHandler( 4946): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:899)
E/GeckoCrashHandler( 4946): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:694)


Steps

i) With a new profile in Nightly launch Nightly Search
ii) Back out and launch the browser
Status: RESOLVED → REOPENED
tracking-fennec: --- → ?
Resolution: DUPLICATE → ---
See Also: → 1123688
Assignee: nobody → rnewman
tracking-fennec: ? → 38+
Status: NEW → ASSIGNED
Component: General → Profile Handling
This should be fixed by Bug 1123688.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1123688
You need to log in before you can comment on or make changes to this bug.