If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

IndexedDB Unkown Error @ ActorsParent.cpp:414 when calling indexedDB.open

RESOLVED FIXED in mozilla38

Status

()

Core
DOM: IndexedDB
--
major
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: brunoais, Assigned: janv)

Tracking

37 Branch
mozilla38
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 2 obsolete attachments)

69.60 KB, text/plain
Details
70.22 KB, text/plain
Details
1.51 KB, text/plain
Details
5.04 KB, patch
Ben Turner (not reading bugmail, use the needinfo flag!)
: review+
Details | Diff | Splinter Review
(Reporter)

Description

3 years ago
When trying to open the database, firefox displays the error in the console:
Originally, on firefox 35:
> IndexedDB UnknownErr: ActorsParent.cpp:412 <unknown>
> UnknownError <unknown>
On firefox nightly 38.0a1 (2015-01-21):
> IndexedDB UnknownErr: ActorsParent.cpp:414 <unknown>
> UnknownError <unknown>

The database works correctly in firefox 24.0.5 on WOW64 windows 6.1SP1

I may not give you a copy of the database because it contains private information.
The website that it belongs to is private although maintained by me.

Other than that, I can try anything to help you solving this issue. Just ask whatever you need to try to get the help required to fix this bug.


Note:I believe this is not #1093223 because it is marked as fixed and I still get it on nightly.
See Also: → bug 1093223
(Assignee)

Comment 1

3 years ago
Can you try it with a debug build ?
For example: ftp://ftp.mozilla.org/pub/firefox/tinderbox-builds/mozilla-central-win64-debug/latest/
(Reporter)

Comment 2

3 years ago
Created attachment 8553009 [details]
Startup Crash debug log

I can't test properly. Firefox nightly crashes while starting.
Here's the max debug backlog I was able to obtain from the console.
Any suggestions?
(Assignee)

Comment 3

3 years ago
Hm, that build looks broken. What about http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/mozilla-release-win32-debug/latest/
(Reporter)

Comment 4

3 years ago
Created attachment 8553089 [details]
startupCrash.txt

That one crashed too.
Windows debug builds require the debug CRT, which means you have to have the compiler installed.
Although maybe we changed that at some point.  Not sure.
(Assignee)

Comment 7

3 years ago
Oh, thanks for the info.

brunoaiss, are you able to install MSVC ?
Here is some info:
https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/Build_Instructions/Windows_Prerequisites
(Reporter)

Comment 8

3 years ago
Created attachment 8553225 [details]
booting crash log

Same thing happened.
I did install MSVC, though. I even rebooted my PC (it didn't tell me to but I did it anyway)
(Reporter)

Comment 9

3 years ago
Oh, I'm not sure if this is useful but:

This is happening while starting firefox and it is taking around 5 minutes to crash while booting. Can it be data overload due to too much information on sessionStore.json?
(Assignee)

Comment 10

3 years ago
Sorry, I have no idea why it doesn't work for you. You could build your own firefox, but I'm not sure if you have so much time to figure it out.
(Reporter)

Comment 11

3 years ago
Would I be able to test it properly if I make a new profile and just copy the "storage" directory to it?
It seems like the main reason it is choking is related to the amount of tabs I use.
Flags: needinfo?(Jan.Varga)
(Assignee)

Comment 12

3 years ago
Man, how many tabs do you have ? :)

Yeah, try to create a new profile and copy the storage directory to it.
Flags: needinfo?(Jan.Varga)
(Reporter)

Comment 13

3 years ago
Oh! Would it work if I clone the whole profile and just remove sessionstore so that it starts fresh on that end?
(Reporter)

Comment 14

3 years ago
I've been having ~1200 tabs open. From which, I use all every month and around 1/10th of all every 1/2 week :D.
I'll try that, then
(Reporter)

Comment 15

3 years ago
I forgot to mention:
They are spread along some dozens of tab groups.
(Reporter)

Comment 16

3 years ago
Sheeeeesh! Really?

> [15924] WARNING: Something (https+++*******.folder.bak) in the repository that doesn't belong!: file c:\builds\moz2_slave\m-cen-w64-d-000000000000000000\build\dom\quota\QuotaManager.cpp, line 1949

That's a file my backup script created (the "*******" is censoring I'm applying). It would be so much helpful if I actually had a proper error message without having to go all the way to debug mode to be able to get there.
As far as I know, this was not on any of the dev notes/dev log I read about firefox 35 <_>.

Feel free to change the status if I didn't choose the correct one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
Hmm, should we be more resilient here?
Flags: needinfo?(Jan.Varga)
(Assignee)

Comment 18

3 years ago
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) (Away 1/22-2/8) from comment #17)
> Hmm, should we be more resilient here?

Do you mean to add a JS console warning ?
Or just ignore unknown files ?
Flags: needinfo?(Jan.Varga)
I meant the latter, although if we don't do that the former might be nice.
(Reporter)

Comment 20

3 years ago
I agree with Kyle.
(Assignee)

Comment 21

3 years ago
Hm, I just realized that we are not so strict in some other cases, like deleting origin directories. So I'm going to reopen this bug and provide a simple patch to just ignore unknown files during repository initialization.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WONTFIX → ---
(Assignee)

Comment 22

3 years ago
Created attachment 8554527 [details] [diff] [review]
patch

Ben, just look for the word "belong" in QuotaManager.cpp to see that we just warn in other cases.
Assignee: nobody → Jan.Varga
Status: REOPENED → ASSIGNED
Attachment #8554527 - Flags: review?(bent.mozilla)
Comment on attachment 8554527 [details] [diff] [review]
patch

Review of attachment 8554527 [details] [diff] [review]:
-----------------------------------------------------------------

I'm a little nervous about this... If we have random files floating around in the storage directory then we're likely going to get something wrong when calculating quota, or clearing origins, etc. I think I'd prefer we go the other way and just put an entry in the error console.
Attachment #8554527 - Flags: review?(bent.mozilla) → review-
(Assignee)

Comment 24

3 years ago
Created attachment 8555207 [details] [diff] [review]
patch

Ok, let's go with the other option then.

This patch changes the internal error message format a bit
Old format:
IndexedDB UnknownErr: ActorsParent.cpp:414

New format:
indexedDB: UnknownErr: ActorsParent.cpp:414

The warning for actual quota manager error looks like this:
quota: Something (https+++*******.folder.bak) in the repository that doesn't belong!: QuotaManager.cpp:1920
Attachment #8555207 - Flags: review?(bent.mozilla)
Comment on attachment 8555207 [details] [diff] [review]
patch

Review of attachment 8555207 [details] [diff] [review]:
-----------------------------------------------------------------

::: dom/base/nsContentUtils.h
@@ +819,5 @@
>                                    uint32_t aLineNumber = 0,
>                                    uint32_t aColumnNumber = 0);
>  
> +  static void
> +  ReportInternalErrorToConsole(const char* aModule,

I don't think this is generic enough to move to nsContentUtils. Let's just keep calling LogSimpleConsoleError in QM/IDB.
Attachment #8555207 - Flags: review?(bent.mozilla) → review-
(Assignee)

Comment 26

3 years ago
Created attachment 8556747 [details] [diff] [review]
patch

Third time's the charm.
Attachment #8554527 - Attachment is obsolete: true
Attachment #8555207 - Attachment is obsolete: true
Attachment #8556747 - Flags: review?(bent.mozilla)
Comment on attachment 8556747 [details] [diff] [review]
patch

Looks good!
Attachment #8556747 - Flags: review?(bent.mozilla) → review+
(Assignee)

Comment 28

3 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/c6b67adc757c
https://hg.mozilla.org/mozilla-central/rev/c6b67adc757c
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
You need to log in before you can comment on or make changes to this bug.