Closed Bug 1124248 Opened 7 years ago Closed 7 years ago

[Bluetooth] Bluetooth can not be enabled

Categories

(Firefox OS Graveyard :: Bluetooth, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.5?, b2g-v2.2 unaffected, b2g-master affected)

RESOLVED WORKSFORME
blocking-b2g 2.5?
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- affected

People

(Reporter: jmitchell, Unassigned)

Details

(Keywords: regression, smoketest, Whiteboard: [3.0-Daily-Testing])

Attachments

(1 file)

Description:
Bluetooth can not be successfully enabled. Active devices in the area can not be found; device itself can not be seen by other devices; 'rename my device' is not selectable. 


Repro Steps:
1) Update a Flame to 20150121010204
2) Launch Settings
3) Select Bluetooth 
4) Attempt to find devices, rename device, etc

Actual:
Bluetooth is not properly enabled, device can not find others, shows as 'Turned off' on settings menu

Expected:
Bluetooth will work properly. 

Environmental Variables:
Device: Flame 3.0
Build ID: 20150121010204
Gaia: 5e98dc164b17fd6decb48a9eaddef0e55b82e249
Gecko: 540077a30866
Gonk: a814b2e2dfdda7140cb3a357617dc4fbb1435e76
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro frequency: 5/5
Link to failed test case: https://moztrap.mozilla.org/manage/case/6071/
See attached: logcat 

-----------------------------------------------------------------------------------

Issue does not repro on 2.2

Device: Flame 2.2 (KK - Nightly - full flashed)
Build ID: 20150121002607
Gaia: e4f9b5da3751798f9cc5d95f302c30722cc11fca
Gecko: 75a462a58d7a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]:
Regression of a core feature that fails smoketests.

Requesting a window.
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
QA Contact: bzumwalt
B2G-Inbound Gecko Regression Window:

Last working B2G-Inbound build:
Device: Flame 3.0 Master
BuildID: 20150120001341
Gaia: 90e1a2525d3cded5945cfaee277ac8d6075beb8c
Gecko: f0d42391b5fd
Version: 38.0a1 (3.0)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

First broken B2G-Inbound build:
Device:  Flame 3.0 Master
BuildID: 20150120011239
Gaia: a47ec54a7040d6f689c3eabd2f23bb510c78c0cd
Gecko: fc9006e38f20
Version: 38.0a1 (3.0)
Firmware: V18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0


Working Gaia with Broken Gecko issue DOES occur:
Gaia: 90e1a2525d3cded5945cfaee277ac8d6075beb8c
Gecko: fc9006e38f20

Working Gecko with Broken Gaia issue does NOT occur:
Gaia: a47ec54a7040d6f689c3eabd2f23bb510c78c0cd
Gecko: f0d42391b5fd

Gecko B2G-Inbound Pushlog: 
http://hg.mozilla.org/integration/b2g-inbound/pushloghtml?fromchange=f0d42391b5fd&tochange=fc9006e38f20

Appears to have been caused by Bug 1065336
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Thomas, can you take a look at this please? Looks like the work done on bug 1065336 may have caused this issue.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(tzimmermann)
Only flashing |gecko + gaia| is not enough to bring all those changes onto the device. boot.img need to be flashed as well.

I can enable/disable the bluetooth function by flashing my flame with v18D and the latest PVT build:
Gaia      917b6c36717fddc6e71ffc1ec249633c8044c93c
Gecko     https://hg.mozilla.org/mozilla-central/rev/34e2d2bd7ec4
BuildID   20150121160202
Version   38.0a1
ro.build.version.incremental=eng.cltbld.20150121.192948
ro.build.date=Wed Jan 21 19:29:59 EST 2015
Hi Joshua, can you try Comment 4 and see if the issue still reproduce? Thanks.
Flags: needinfo?(jmitchell)
Bruce had tried the latest PVT build via full flash all images and it works. So I prefer to waif for confirmation from jmitchell.
Status: NEW → UNCONFIRMED
Ever confirmed: false
Flags: needinfo?(tzimmermann)
Yes, Flashing the boot image as well did fix the bluetooth issue. resolving as WFM
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Flags: needinfo?(jmitchell)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.