Closed Bug 1124268 Opened 5 years ago Closed 5 years ago

nsContentUtils::GetSameOriginChecker() is infallible


(Core :: DOM: Core & HTML, defect)

Not set





(Reporter: mccr8, Assigned: mccr8)



(3 files)

No description provided.
I could rename it to nsContentUtils::SameOriginChecker(), but it causes some weirdness because the class in nsContentUtils has the same name.
Comment on attachment 8552707 [details] [diff] [review]
Take advantage of the infallibility of nsContentUtils::GetSameOriginChecker().

Annoying to keep Get prefix.
At least add a comment to .h that the method is infallible.
Attachment #8552707 - Flags: review?(bugs) → review+
I could rename the class to SameOriginCheckerImpl or something, and then rename the method.  Technically I can do "new class SameOriginChecker" but I've never seen that before in Gecko code, so I worry about it working across all the compilers we care about.
*Impl sounds ok to me, given the class is internal to .cpp.
This method is infallible, so the name should reflect that.
Attachment #8553846 - Flags: review?(bugs)
Attachment #8553845 - Flags: review?(bugs) → review+
Attachment #8553846 - Flags: review?(bugs) → review+
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.