If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

nsGfxTextControlFrameState2::Destroy() should not trigger calls into the editor

VERIFIED FIXED in mozilla1.1alpha

Status

()

Core
Editor
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: kinmoz, Assigned: John Keiser (jkeiser))

Tracking

Trunk
mozilla1.1alpha
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
This bug was split off from crasher bug 109754, which was fixed with a simple
null check, but the cause is still present ...

The basic problem is that the rev 1.170 checkin to nsGfxTextControlFrame2.cpp by
jst/jkeiser, modified the Destroy() method to call GetTextControlFrameState(),
which uses the editor.

We shouldn't be doing that since at the time Destroy() is called, there are no
guarantees that some of the things the editor relies on, for example style
contexts, content, etc., are going to be around.

We need to find some other place to retrieve the value of the editor, before
Destroy() is called. Perhaps the frame manager has a notification we can hook into?
(Assignee)

Updated

16 years ago
Blocks: 74091
(Assignee)

Comment 1

16 years ago
Setting milestone to 1.0 because of bug 74091.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0
Moving to Moz1.1
Target Milestone: mozilla1.0 → mozilla1.1
(Assignee)

Updated

16 years ago
Blocks: 133357
(Assignee)

Comment 3

16 years ago
This was fixed in bug 132334.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 4

16 years ago
code level fix; need help from development to verify. Charley/Kathy, can you
please verify these and mark verified-fixed ? thanks.

Comment 5

16 years ago
verified....
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.