Intermittent browser_bug1015721.js | Tab 2 should have zoomed along with tab 1 - Got 1, expected 1.100000023841858

RESOLVED FIXED in Firefox 37

Status

()

defect
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: KWierso, Assigned: ttaubert)

Tracking

({intermittent-failure})

unspecified
Firefox 39
x86_64
macOS
Points:
1
Dependency tree / graph
Bug Flags:
firefox-backlog +
in-testsuite +
qe-verify -

Firefox Tracking Flags

(firefox36 wontfix, firefox37 fixed, firefox38 fixed, firefox39 fixed, firefox-esr31 unaffected, firefox-esr38 fixed)

Details

Attachments

(2 attachments)

12:22:39 INFO - 80 INFO TEST-START | browser/base/content/test/general/browser_bug1003461-switchtab-override.js
12:22:39 INFO - 81 INFO TEST-OK | browser/base/content/test/general/browser_bug1003461-switchtab-override.js | took 88ms
12:22:39 INFO - ++DOCSHELL 0x12e3f2800 == 31 [pid = 1981] [id = 103]
12:22:39 INFO - ++DOMWINDOW == 115 (0x112c10800) [pid = 1981] [serial = 294] [outer = 0x0]
12:22:39 INFO - ++DOMWINDOW == 116 (0x113b49c00) [pid = 1981] [serial = 295] [outer = 0x112c10800]
12:22:39 INFO - [1981] WARNING: NS_ENSURE_TRUE(mMutable) failed: file /builds/slave/fx-team-osx64-d-00000000000000/build/src/netwerk/base/nsSimpleURI.cpp, line 265
12:22:39 INFO - 82 INFO TEST-START | browser/base/content/test/general/browser_bug1015721.js
12:22:39 INFO - ++DOCSHELL 0x136442800 == 32 [pid = 1981] [id = 104]
12:22:39 INFO - ++DOMWINDOW == 117 (0x1358ac000) [pid = 1981] [serial = 296] [outer = 0x0]
12:22:39 INFO - ++DOMWINDOW == 118 (0x13606bc00) [pid = 1981] [serial = 297] [outer = 0x1358ac000]
12:22:39 INFO - ++DOCSHELL 0x141ec8800 == 33 [pid = 1981] [id = 105]
12:22:39 INFO - ++DOMWINDOW == 119 (0x136750c00) [pid = 1981] [serial = 298] [outer = 0x0]
12:22:39 INFO - ++DOMWINDOW == 120 (0x136753400) [pid = 1981] [serial = 299] [outer = 0x136750c00]
12:22:39 INFO - [1981] WARNING: NS_ENSURE_TRUE(mMutable) failed: file /builds/slave/fx-team-osx64-d-00000000000000/build/src/netwerk/base/nsSimpleURI.cpp, line 265
12:22:39 INFO - ++DOMWINDOW == 121 (0x1374acc00) [pid = 1981] [serial = 300] [outer = 0x136750c00]
12:22:39 INFO - ++DOMWINDOW == 122 (0x1374ab400) [pid = 1981] [serial = 301] [outer = 0x1358ac000]
12:22:39 INFO - ++DOMWINDOW == 123 (0x141315400) [pid = 1981] [serial = 302] [outer = 0x136750c00]
12:22:40 INFO - [1981] WARNING: NS_ENSURE_TRUE(domDoc && target) failed: file /builds/slave/fx-team-osx64-d-00000000000000/build/src/dom/base/nsContentUtils.cpp, line 3576
12:22:40 INFO - [1981] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80070057: file /builds/slave/fx-team-osx64-d-00000000000000/build/src/dom/base/nsContentUtils.cpp, line 3649
12:22:40 INFO - 83 INFO checking window state
12:22:40 INFO - 84 INFO Wait tab event: load
12:22:40 INFO - 85 INFO Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://example.org/browser/browser/base/content/test/general/zoom_test.html" line: 0}]
12:22:40 INFO - 86 INFO Tab event received: load
12:22:40 INFO - 87 INFO Wait tab event: load
12:22:40 INFO - 88 INFO Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://example.org/browser/browser/base/content/test/general/zoom_test.html" line: 0}]
12:22:40 INFO - 89 INFO Tab event received: load
12:22:40 INFO - 90 INFO TEST-PASS | browser/base/content/test/general/browser_bug1015721.js | Tab 1 is selected
12:22:40 INFO - 91 INFO TEST-PASS | browser/base/content/test/general/browser_bug1015721.js | Initial zoom of tab 1 should be 1
12:22:40 INFO - 92 INFO TEST-PASS | browser/base/content/test/general/browser_bug1015721.js | Initial zoom of tab 2 should be 1
12:22:40 INFO - 93 INFO TEST-PASS | browser/base/content/test/general/browser_bug1015721.js | New zoom for tab 1 should be greater than 1
12:22:40 INFO - 94 INFO TEST-UNEXPECTED-FAIL | browser/base/content/test/general/browser_bug1015721.js | Tab 2 should have zoomed along with tab 1 - Got 1, expected 1.100000023841858
12:22:40 INFO - Stack trace:
12:22:40 INFO - chrome://mochikit/content/browser-test.js:test_is:851
12:22:40 INFO - chrome://mochitests/content/browser/browser/base/content/test/general/head.js:zoomTest:514
12:22:40 INFO - chrome://mochitests/content/browser/browser/base/content/test/general/browser_bug1015721.js:zoomTab1/<:42
12:22:40 INFO - self-hosted:next:660
12:22:40 INFO - zoomTab1@chrome://mochitests/content/browser/browser/base/content/test/general/browser_bug1015721.js:30:3
12:22:40 INFO - Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:870:23
12:22:40 INFO - this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:749:7
12:22:40 INFO - this.PromiseWalker.scheduleWalkerLoop/<@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:691:37
12:22:40 INFO - [1981] WARNING: NS_ENSURE_TRUE(mMutable) failed: file /builds/slave/fx-team-osx64-d-00000000000000/build/src/netwerk/base/nsSimpleURI.cpp, line 265
12:22:40 INFO - 95 INFO MEMORY STAT vsize after test: 3633852416
12:22:40 INFO - 96 INFO MEMORY STAT residentFast after test: 468307968
12:22:40 INFO - 97 INFO MEMORY STAT heapAllocated after test: 143550944
12:22:40 INFO - 98 INFO TEST-OK | browser/base/content/test/general/browser_bug1015721.js | took 1611ms
12:22:40 INFO - ++DOCSHELL 0x141edb800 == 34 [pid = 1981] [id = 106]
12:22:40 INFO - ++DOMWINDOW == 124 (0x135894400) [pid = 1981] [serial = 303] [outer = 0x0]
12:22:41 INFO - ++DOMWINDOW == 125 (0x1374a9800) [pid = 1981] [serial = 304] [outer = 0x135894400]
12:22:41 INFO - [1981] WARNING: NS_ENSURE_TRUE(mMutable) failed: file /builds/slave/fx-team-osx64-d-00000000000000/build/src/netwerk/base/nsSimpleURI.cpp, line 265
12:22:41 INFO - 99 INFO TEST-START | browser/base/content/test/general/browser_bug1024133-switchtab-override-keynav.js
hmm, so what did we uplift to beta to make this start happening there too?
Drew, you've fixed similar bugs in the past. Any chance you'd have some spare cycles to look into this one?
Flags: needinfo?(adw)
Sorry, with the iteration/sprint/agile model that the desktop team is using, it's hard to pick up bugs that aren't prioritized by management.  I'll add this to the backlog though.
Flags: needinfo?(adw) → firefox-backlog+
Blocks: 1015721
Assignee: nobody → ttaubert
Status: NEW → ASSIGNED
Iteration: --- → 39.2 - 23 Mar
Points: --- → 1
Can reproduce locally. The culprit are these lines added to EventStateManager::DoScrollZoom() by bug 1015721:

> nsContentUtils::DispatchChromeEvent(mDocument, static_cast<nsIDocument*>(mDocument),
>                                     NS_LITERAL_STRING("ZoomChangeUsingMouseWheel"),
>                                     true, true);

mDocument is sometimes null and the event isn't dispatched. I think this should be a proper fix and works for me locally.
Attachment #8578592 - Flags: review?(mstange)
Comment on attachment 8578592 [details] [diff] [review]
0001-Bug-1124409-Fix-intermittent-browser_bug1015721.js-f.patch

Guess Olli could take a look at this as well. Trying to speed up review because that's currently the top intermittent failure on my radar at least.
Attachment #8578592 - Flags: review?(bugs)
(In reply to Olli Pettay [:smaug] from comment #25)
> Comment on attachment 8454385 [details] [diff] [review]
> part 1: add ZoomChangeUsingMouseWheel event
> 
> >+      nsContentUtils::DispatchChromeEvent(mDocument, static_cast<nsIDocument*>(mDocument),
> >+                                          NS_LITERAL_STRING("ZoomChangeUsingMouseWheel"),
> >+                                          true, true);
> true, false)

(That comment is from bug 1015721.)

I just noticed that it seems like the review comment wasn't addressed before landing. Should it? Could do that in the same patch.
Comment on attachment 8578592 [details] [diff] [review]
0001-Bug-1124409-Fix-intermittent-browser_bug1015721.js-f.patch

Thank you for fixing this! I don't know this code very well so I'll defer to Olli. But this looks correct, at least.
Attachment #8578592 - Flags: review?(mstange)
Comment on attachment 8578592 [details] [diff] [review]
0001-Bug-1124409-Fix-intermittent-browser_bug1015721.js-f.patch

Old odd code. We should just have mDocument pointing to the right object
once we have prescontext... oh well, if this helps, fine :)
Attachment #8578592 - Flags: review?(bugs) → review+
Flags: qe-verify?
Flags: qe-verify? → qe-verify-
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #206)
> This made mochitest-e10s-2 permafail.
> https://treeherder.mozilla.org/logviewer.html#?job_id=7715995&repo=mozilla-
> inbound

TEST-UNEXPECTED-FAIL | dom/events/test/test_bug741666.html | Touch has correct screenX - got 67, expected 60
TEST-UNEXPECTED-FAIL | dom/events/test/test_bug741666.html | Touch has correct screenY - got 342, expected 306

After some bisecting, turns out test_bug659071.html that runs before it is the culprit.
Comment on attachment 8578914 [details] [diff] [review]
0002-Bug-1124409-Fix-test_bug659071.html-to-properly-rese.patch

ah, wheel to the other direction.
Attachment #8578914 - Flags: review?(bugs) → review+
https://hg.mozilla.org/mozilla-central/rev/bdb05106d618
https://hg.mozilla.org/mozilla-central/rev/c70e9979e49b
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 39
You need to log in before you can comment on or make changes to this bug.