Closed Bug 1124415 Opened 5 years ago Closed 5 years ago

Can't add linebreaks after refresh, not in sync

Categories

(DevTools :: Debugger, defect)

37 Branch
x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1122064

People

(Reporter: jsantell, Unassigned)

Details

Attachments

(1 file)

Attached image debuggerbug.gif
Really weird error here. Attached is a gif of the STR. Do it in a private window because it seems like state has to do with it.

Load http://todomvc.com/examples/backbone/
Open debugger, put a break on `todo-view.js`::line 51 (or the line with `this.$el.html(this.template(this.model.toJSON()));`)
REFRESH
The line break is now on line 58, and I can't add a line break where it originally was, the checkbox is out-of-sync with the line break bubble next to the source code, and does not perform a line break when the line is evaluated.

Sorry that this seems to be a few issues all in one, but not sure what's related to what.
The core of this issue is bug 1122064, which we have a fix for and are going to uplift to aurora/beta (where it unfortunately got to).

The mismatched sliding breakpoint/etc are related to other UI issues that we may already have bugs for. If not I will try to reproduce it and file a new bug soon. I've seen it myself in other places. It's in the UI code unrelated to the above bug. I think it's even in current release Firefox.
Great, thanks James. Once that lands, I'll see if I can break this bug down into further bugs
bug 1122064 has landed, so if you pull it down you will get it. I'm working on a patch that we can uplift.
@jsantell, can you rename this bug to reflect whatever happens now on Dev Edition? The fix has landed there so please let me know what is still broken. If you can't find anything related to this, mark this as invalid or something.
Using 37.0a2 dev edition looks like it fixed the issue! The line breaks persist and I can add new ones just fine. Resolving this.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1122064
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.