[Windows Management] When turning the screen off and back on quickly while on the downloading preview page a screen corruption (rainbow static) can be seen momentarily if screen lock is not enabled.

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: jmitchell, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [3.0-Daily-Testing], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8552738 [details]
logcat_20150121_1521.txt

Description:
When you click on a downloading file you are taken to the download page of the settings app (a preview / temporary version) of it. If you quickly lock and then unlock the phone (with lockscreen disabled) you can see a brief glimpse of graphical corruption in the form of multi-colored static.
The timing seems to be very specific - if you unlock the device too quick it will remain on the downloads page but if you unlock it too slow it will have left the downloads page and returned to the most previous page you were on. The bug occurs when unlocking during the transition between the two.
This was also seen only once when locking / unlocking while on the notification menu during an update download. 

It is conceivable that this will also occur in other places where there is an off-screen (unseen) transition from current screen after the device is locked. 

Repro Steps:
1) Update a Flame to 20150121010204
2) Disable Screenlock via Settings > Screen Lock
3) Begin downloading a file (larger file through Data (w/ wifi off) works best so you have plenty of time)
4) Click on the downloading notification in the notification menu to be taken to the download page
5) quickly lock and unlock the device


Actual:
static / graphical corruption can be seen

Expected:
no corruption

Environmental Variables:
Device: Flame 3.0
Build ID: 20150121010204
Gaia: 5e98dc164b17fd6decb48a9eaddef0e55b82e249
Gecko: 540077a30866
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 38.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

Repro frequency: 3/12
See attached: logcat, Video: http://youtu.be/hCmliTKaOD4
unfortunately this issue is difficult to capture in a video because of the quickness of the bug and the slowness of the camera to react from going to black to bright screens. 

-------------------------------------------------------------------------------------------
This issue DOES repro on Flame 2.2 (v18d), 2.2 (v18d-1)

Device: Flame 2.2 (KK - Nightly - Full Flash)
Build ID: 20150121002607
Gaia: e4f9b5da3751798f9cc5d95f302c30722cc11fca
Gecko: 75a462a58d7a
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0

Device: Flame 2.2 (KK - Nightly - Full Flash)
Build ID: 20150120002507
Gaia: f5b3d1b6cfa3e702033f613915ae637cb735cbfb
Gecko: 5d7497ce4cc7
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 37.0a2 (2.2)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
-------------------------------------------------------------------------------------
This issue DOES repro on  2.1 (v18d-1)

Actual Results : While sometimes a transition (white screen sliding left) can be seen no graphic corruption is present

Device: Flame 2.1 (KK - Nightly - Full Flash)
Build ID: 20150120001202
Gaia: 77c57eb8a985d5cbd34a597fb1b978ba6e205af6
Gecko: f05d0a2d2378
Gonk: e7c90613521145db090dd24147afd5ceb5703190
Version: 34.0 (2.1)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
NI on component owner for nomination decision and assignment.  It's a low reproducible regression creating a bad user experience (Graphical anomaly).
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga) → needinfo?(gchang)
NI window management owner for this.
Flags: needinfo?(gchang) → needinfo?(hcheng)
Alive, could you please take a look?
Flags: needinfo?(hcheng) → needinfo?(alive)
I don't think this is a gaia issue. Please reach graphic team.
:aus do you know the detail about how we open the download page?
Flags: needinfo?(alive) → needinfo?(aus)

Comment 5

4 years ago
We open the download page via an Activity telling Settings to start on the Downloads page. There's nothing odd in how we request this to occur. It's all pretty standard. Contacting the gfx team would be my recommendation as well.
Flags: needinfo?(aus)
NI gfx team developer.
Flags: needinfo?(mchang)
Flags: needinfo?(mchang)
Is it possible to reproduce this if we set the preference "layers.enable-tiles" to false?
(In reply to Mason Chang [:mchang] from comment #7)
> Is it possible to reproduce this if we set the preference
> "layers.enable-tiles" to false?

Could you please try it?
Flags: needinfo?(jmitchell)
Adding qawanted to tryout Comment 7.
Keywords: qawanted
I added the following line to pref.js file:

user_pref("layers.enable-tiles", false);

and pushed it to Flame. Issue is still reproducible afterwards. Device sometimes shows a full screen of graphical corruption for about a second when repeating step 4 to 5 of STR.

Tested on:
Device: Flame 3.0 Master
BuildID: 20150121052335
Gaia: e45c5dbdcfc2d598c889dfbea72fa11157422afe
Gecko: 0f2b4a7a9daf
Version: 38.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0

-----

I wasn't able to test this on latest central and 2.2 due to bug 1133008 occurring right after step 4 which prevents me to do step 5 in the correct timing that would have repro this bug.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(jmitchell) → needinfo?(ktucker)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(In reply to Pi Wei Cheng [:piwei] from comment #10)
> I added the following line to pref.js file:
> 
> user_pref("layers.enable-tiles", false);
> 
> and pushed it to Flame. Issue is still reproducible afterwards. Device
> sometimes shows a full screen of graphical corruption for about a second
> when repeating step 4 to 5 of STR.
> 
> Tested on:
> Device: Flame 3.0 Master
> BuildID: 20150121052335
> Gaia: e45c5dbdcfc2d598c889dfbea72fa11157422afe
> Gecko: 0f2b4a7a9daf
> Version: 38.0a1 (3.0 Master) 
> Firmware Version: v18D-1
> User Agent: Mozilla/5.0 (Mobile; rv:38.0) Gecko/38.0 Firefox/38.0
> 
> -----
> 
> I wasn't able to test this on latest central and 2.2 due to bug 1133008
> occurring right after step 4 which prevents me to do step 5 in the correct
> timing that would have repro this bug.

Since bug 1133008 is resolved, could you try again? Thanks.
Flags: needinfo?(pcheng)
(Reporter)

Comment 12

4 years ago
This issue no longer occurs - most likely fixed by bug 1133008
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(pcheng)
Resolution: --- → WORKSFORME
(Reporter)

Comment 13

4 years ago
Device: Flame 3.0 (KK - Nightly - Full Flash - 319mem)
Build ID: 20150311010231
Gaia: 943c8b4039f59b08ba100390e164a076a20c892e
Gecko: fd8e079d6335
Gonk: ebad7da532429a6f5efadc00bf6ad8a41288a429
Version: 39.0a1 (Master)
Firmware Version: v188-1
User Agent: Mozilla/5.0 (Mobile; rv:39.0) Gecko/39.0 Firefox/39.0
You need to log in before you can comment on or make changes to this bug.