console errors occur when changing language in general

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: Jamie_, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150116202339

Steps to reproduce:

apptype	b2g
vendor	Mozilla
name	B2G
version	3.0.0.0-prerelease
appbuildid	20150121010204
platformbuildid	20150121010204
platformversion	38.0a1
geckobuildid	20150121010204
geckoversion	38.0a1
changeset	540077a30866

while running 3.0 build in webIDE b2g change language


Actual results:

when changing if you look at the console it pops up with this error

"L10nError: "collection-categoryId-undefined" not found in en-US in app://verticalhome.gaiamobile.org/index.html#root" "
    at reportMissingEntity (app://verticalhome.gaiamobile.org/shared/js/l10n.js:1513:8)"
(Reporter)

Comment 1

4 years ago
only happens on initial run.... not sure why, also 

"L10nError: "collection-categoryId-undefined" not found in en-US in app://verticalhome.gaiamobile.org/index.html#root" "
    at reportMissingEntity (app://verticalhome.gaiamobile.org/shared/js/l10n.js:1513:8)"

and also on initial run I get

"IccHelper isn't enabled. SingleVariant configuration can't be loaded" "
    at loadSingleVariantConf (app://verticalhome.gaiamobile.org/js/configurator.js:44:0)
    at onLoadInitJSON (app://verticalhome.gaiamobile.org/js/configurator.js:132:4)"
(Reporter)

Updated

4 years ago
Duplicate of this bug: 1124252
(Reporter)

Comment 3

4 years ago
this is no longer popping up in the console log while switching languages now.... so this will be marked as resolved works for me.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.