Windows XP File Protection deletes critical file

CLOSED WORKSFORME

Status

Core Graveyard
File Handling
--
critical
CLOSED WORKSFORME
17 years ago
2 years ago

People

(Reporter: Michel Thomas, Assigned: Bill Law)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.6) Gecko/20011120
BuildID:    2001112009

After installing Mozilla 0.9.6, Windows File Protection detects an
unrecognizable file and restores a back up automatically on restart. So after
restarting windows, Mozilla will not run all I get is a small window in the top
left corner that is non responsive.  I’ve tried reinstalling Windows XP and the
only thing I installed was Mozilla, (same result) This Bug does not happen with
Mozilla 0.9.5  (On my system anyway). So I have to reinstall Mozilla every time
I reboot windows (Witch is quite Often Obviously using windows)

Comment 1

17 years ago
I can imagine Microsoft's reaction :
"This behaviour is by design."
or
"That's not a bug, it's a feature."



(Sorry)
which file is restored ?
(look in the evennt log)
bill?
Assignee: pchen → law
Component: XP Apps → File Handling
Keywords: qawanted
from email :
--------------------------------------------------------------------------
pubprn.vbs
prnqctl.vbs
prnport.vbs
prnmngr.vbs
prnjobs.vbs
prndrvr.vbs
prncnfg.vbs
pagefileconfig.vbs
eventquery.vbs

These are the name of the file that were restored upon restart, They are all
VBScript files, so I turned off the Indexing Service and archiving for all my
files and this seem to have done the trick. I've rebooted several times and no
problems so far.
-----------------------------------------------------------------------

Reporter: 
Please use the bugzilla URL, add your comments in the additional comments field
and hit the "commit" button :-)
Severity: blocker → critical

Comment 5

17 years ago
How do these .vbs files affect mozilla?  
The should have no be effect whatsoever.

Is your profile located on \Documents and Settings\...user..\Application
Data\Mozilla  ? 

Comment 6

16 years ago
shouldn't we move this one to WONTFIX? since i run XP and did several
installations of moz0.9.7, 0.9.8 and nightlies without the mentioned problems. i
can't confirm the problem, since i didn't install 0.9.6 on XP - but if someone
insists, i can try so. nevertheless i CAN say, it works with newer releases, so
i suggest forgetting about this, unless it would reappear in a newer build?
comments?
this files are not used by Mozilla.
Mozilla doesn't use any system drivers (except Mapi.dll)
It works on my WIN XP and also no one else see this problem.

marking workforme

Comment 8

16 years ago
Sorry matti, you did not =)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
true :-)
mass-verifying WorksForMe bugs.

reopen only if this bug is still a problem with a *recent trunk build*.

mail search string for bugspam: AchilleaMillefolium
Status: RESOLVED → VERIFIED
(Reporter)

Comment 11

16 years ago
I have not had any problems with recent builds so I guess it is solved. Also I
talked to all my friends and it seemed it was only I that had the problem. I
don't know what caused the problem but it is working fine now after installing a
newer build. Problem solved so great work guys   :)
Status: VERIFIED → CLOSED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.