Graphical glitch during animation

RESOLVED FIXED in Firefox 37

Status

()

RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: alice0775, Assigned: mattwoodrow)

Tracking

(Blocks: 1 bug, {regression})

34 Branch
mozilla38
x86_64
All
regression
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?
qe-verify -

Firefox Tracking Flags

(firefox35 wontfix, firefox36+ wontfix, firefox37+ fixed, firefox38+ fixed, firefox-esr31 unaffected)

Details

(Whiteboard: [dupe me])

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8552867 [details]
screenshot during animarion

[Tracking Requested - why for this release]:

[Tracking Requested - why for this release]:

+++ This bug was initially created as a clone of Bug #1123522 +++

I can notice a different glitch from the video(Bug 1123522 attachment 8552787 [details]) on Linux and Windows.
I am not sure this is a same cause or not.
So, I filed a new bug anyway.

Steps to reproduce:
1. Modified js according to Bug 1123522 comment#0
2. Open index.html

Actual results:
See attached screenshot

Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=2a61df4eaa2d&tochange=24ba8274ed60

In local build(win32 non pgo)
Last Good: 2a61df4eaa2d
First Bad: 823227372483

Regressed by 823227372483	Bas Schouten — Bug 1107297: Only recomposite the damaged rect with D3D11. r=jrmuizel
(Reporter)

Comment 1

4 years ago
Created attachment 8552868 [details]
test.zip (Modified one)
(Reporter)

Updated

4 years ago
Attachment #8552868 - Attachment description: test.zip → test.zip (Modified one)
(Reporter)

Comment 2

4 years ago
When disabled HWA, the regression window is different.

Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=06b540d3667a&tochange=912c96edb352

Regressed by Bug 1039926
Blocks: 1039926
status-firefox35: unaffected → affected
status-firefox36: unaffected → affected
Version: 37 Branch → 34 Branch
(Reporter)

Updated

4 years ago
Flags: needinfo?(matt.woodrow)
(Reporter)

Comment 3

4 years ago
[Tracking Requested - why for this release]:
tracking-firefox36: --- → ?
This is a bug in layout incorrectly reporting the damaged rect to the layer manager.
Component: Graphics: Layers → Layout
Matt - Can you take this bug?
status-firefox35: affected → wontfix
tracking-firefox36: ? → +
tracking-firefox37: ? → +
tracking-firefox38: ? → +
(Assignee)

Comment 6

4 years ago
Created attachment 8555629 [details] [diff] [review]
mask-invalidation
Assignee: nobody → matt.woodrow
Flags: needinfo?(matt.woodrow)
Attachment #8555629 - Flags: review?(roc)
Comment on attachment 8555629 [details] [diff] [review]
mask-invalidation

Review of attachment 8555629 [details] [diff] [review]:
-----------------------------------------------------------------

Test?
Attachment #8555629 - Flags: review?(roc) → review+
Matt, could you land this asap? I would like to have the fix in beta 7 (gtb next Thursday).
Thanks
Flags: needinfo?(matt.woodrow)
(Assignee)

Comment 9

4 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/6df246c641de
Flags: needinfo?(matt.woodrow) → in-testsuite?
https://hg.mozilla.org/mozilla-central/rev/6df246c641de
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-firefox38: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
thanks :)
could you fill the uplift request? thanks
(Reporter)

Comment 12

4 years ago
I can still reproduce the problem with/without HWA on the following m-i tinderbox-build.

https://hg.mozilla.org/integration/mozilla-inbound/rev/6df246c641de
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:38.0) Gecko/20100101 Firefox/38.0 ID:20150203134025
Status: RESOLVED → REOPENED
Flags: needinfo?(matt.woodrow)
Resolution: FIXED → ---
Like 35, it seems that 36 is going to ship it this bug. Wontfix then.
status-firefox36: affected → wontfix
status-firefox38: fixed → affected
(Assignee)

Comment 14

4 years ago
Comment on attachment 8555629 [details] [diff] [review]
mask-invalidation

Approval Request Comment
[Feature/regressing bug #]: Bug 1107297
[User impact if declined]: Fixes at least one cause of this bug, possibly not al of them as per comment 12.
[Describe test coverage new/current, TreeHerder]: Tested manually.
[Risks and why]: Very low risk, just an invalidation change
[String/UUID change made/needed]: None.
Flags: needinfo?(matt.woodrow)
Attachment #8555629 - Flags: approval-mozilla-beta?
Attachment #8555629 - Flags: approval-mozilla-aurora?
Comment on attachment 8555629 [details] [diff] [review]
mask-invalidation

Too late in the beta cycle and we already released 35 with this bug.
Let it ride the train with 37
Attachment #8555629 - Flags: approval-mozilla-beta?
Attachment #8555629 - Flags: approval-mozilla-beta-
Attachment #8555629 - Flags: approval-mozilla-aurora?
Attachment #8555629 - Flags: approval-mozilla-aurora+
Matt, I think we should close this out and move comment 12 to a new bug. The uplift is Monday and tracking's going to be a pain otherwise.
status-firefox37: affected → fixed
status-firefox38: affected → fixed
Flags: needinfo?(matt.woodrow)
(Reporter)

Updated

4 years ago
Blocks: 1140362
(Reporter)

Comment 18

4 years ago
(In reply to Ryan VanderMeulen [:RyanVM UTC-5] from comment #17)
> Matt, I think we should close this out and move comment 12 to a new bug. The
> uplift is Monday and tracking's going to be a pain otherwise.

I've filed new Bug 1140362.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
Flags: qe-verify-

Updated

4 years ago
Duplicate of this bug: 1123522
Flags: needinfo?(matt.woodrow)
You need to log in before you can comment on or make changes to this bug.