BluetoothInterface build failure: "error: duplicate 'const'"

RESOLVED FIXED in Firefox 38

Status

()

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: gerard-majax, Assigned: tzimmermann)

Tracking

({regression})

unspecified
mozilla38
ARM
Gonk (Firefox OS)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, firefox36 wontfix, firefox37 wontfix, firefox38 fixed, b2g-v2.2 fixed, b2g-master fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

4 years ago
../../../gecko/dom/bluetooth/BluetoothInterface.cpp: In static member function 'static mozilla::dom::bluetooth::BluetoothInterface* mozilla::dom::bluetooth::BluetoothInterface::GetInstance()':
../../../gecko/dom/bluetooth/BluetoothInterface.cpp:107:3: error: duplicate 'const'

In the directory  /home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/objdir-gecko/dom/bluetooth
The following command failed to execute properly:
/usr/bin/ccache /home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/prebuilts/gcc/linux-x86/arm/arm-linux-androideabi-4.7/bin/arm-linux-androideabi-g++ -o BluetoothInterface.o -c -I../../dist/system_wrappers -include /home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/gecko/config/gcc_hidden.h -DMOZ_B2G_BT_BLUEZ -DOS_POSIX=1 -DOS_LINUX=1 -DSTATIC_EXPORTABLE_JS_API -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -DAB_CD=en-US -DNO_NSPR_10_SUPPORT -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/gecko/dom/bluetooth -I. -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/objdir-gecko/ipc/ipdl/_ipdlheaders -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/gecko/dom/bluetooth/bluez -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/gecko/dom/bluetooth/ipc -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/gecko/dom/bluetooth/../base -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/gecko/dom/bluetooth/../network -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/gecko/dom/bluetooth/../system/gonk -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/gecko/ipc/chromium/src -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/gecko/ipc/glue -I../../dist/include -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/objdir-gecko/dist/include/nspr -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/objdir-gecko/dist/include/nss -fPIC -DANDROID -isystem /home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/bionic/libc/arch-arm/include -isystem /home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/bionic/libc/include -isystem /home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/bionic/libstdc++/include -isystem /home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/bionic/libc/kernel/common -isystem /home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/bionic/libc/kernel/arch-arm -isystem /home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/bionic/libm/include -isystem /home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/bionic/libm/include/arm -isystem /home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/bionic/libthread_db/include -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/system -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/system/core/include -isystem /home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/bionic -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/hardware/libhardware/include -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/external/valgrind/fxos-include -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/frameworks/native/include -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/frameworks/av/include -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/frameworks/av/include/media -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/frameworks/av/include/camera -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/frameworks/native/include/media/openmax -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/frameworks/av/media/libstagefright/include -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/external/dbus -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/external/bluetooth/bluez/lib -DMOZILLA_CLIENT -include ../../mozilla-config.h -MD -MP -MF .deps/BluetoothInterface.o.pp -DANDROID -isystem /home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/bionic/libc/arch-arm/include -isystem /home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/bionic/libc/include -isystem /home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/bionic/libstdc++/include -isystem /home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/bionic/libc/kernel/common -isystem /home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/bionic/libc/kernel/arch-arm -isystem /home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/bionic/libm/include -isystem /home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/bionic/libm/include/arm -isystem /home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/bionic/libthread_db/include -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/system -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/system/core/include -isystem /home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/bionic -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/hardware/libhardware/include -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/external/valgrind/fxos-include -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/frameworks/native/include -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/frameworks/av/include -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/frameworks/av/include/media -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/frameworks/av/include/camera -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/frameworks/native/include/media/openmax -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/frameworks/av/media/libstagefright/include -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/external/dbus -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/external/bluetooth/bluez/lib -Wall -Wempty-body -Woverloaded-virtual -Wsign-compare -Wwrite-strings -Wno-invalid-offsetof -Wno-error=uninitialized -Wno-error=maybe-uninitialized -Wno-error=deprecated-declarations -mandroid -fno-short-enums -fno-exceptions -Wno-psabi -DMOZ_ENABLE_JS_DUMP -include /home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/gonk-misc/Unicode.h -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/gecko/build/stlport/stlport -I/home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/ndk/sources/cxx-stl/system/include -march=armv7-a -mthumb -mfpu=neon -mfloat-abi=softfp -mno-unaligned-access -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -std=gnu++0x -pipe -DNDEBUG -DTRIMMED -g -freorder-blocks -Os -fno-reorder-functions -funwind-tables -Werror /home/alex/codaz/Mozilla/b2g/devices/XperiaZR/B2G/gecko/dom/bluetooth/BluetoothInterface.cpp


This is just because the line is:
> static const char const * sDefaultBackend = nullptr;
(Reporter)

Comment 1

4 years ago
Posted file fix (obsolete) —
Thanks for reporting this bug.
blocking-b2g: --- → 2.2?
Comment on attachment 8552974 [details] [diff] [review]
[01] Bug 1124565: Fix position of const qualifiers for |sDefaultBackend|

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 

Bug 1065336

User impact if declined: 

We might not be able to build v2.2 for platforms without Bluetooth.

Testing completed: 

Local builds and testing.

Risk to taking this patch (and alternatives if risky): 

Very low. The fixed bug is a trivial syntax error that I didn't notice in the original patch.

String or UUID changes made by this patch:

None.
Attachment #8552974 - Flags: approval-mozilla-b2g37?
No longer blocks: 1065336
Depends on: 1065336
https://hg.mozilla.org/mozilla-central/rev/61a48668ad30
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla38
blocking-b2g: 2.2? → 2.2+
Attachment #8552974 - Flags: approval-mozilla-b2g37? → approval-mozilla-b2g37+
Blocks: 1126720
You need to log in before you can comment on or make changes to this bug.