opera-de-nice.com - does not display in Mozilla 0.9.4 (shows fine in Konquerur 2.1.1)

VERIFIED FIXED

Status

Tech Evangelism Graveyard
French
VERIFIED FIXED
17 years ago
3 years ago

People

(Reporter: William Stinson, Assigned: Tristan Nitot)

Tracking

Details

(Whiteboard: [SYNTAX-HTML], URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010914
BuildID:    2001100112

For me this looks like Technical Evangelism (or bad design of the site):

This french site (Nice opera) does not display in Mozilla (latest RPM for
Linux-Mandrake 8.1 distribution =Mozilla 0.9.4
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010914 ). 

Instead the following error message is displayed (in between the asterisks):
***************************************************************************

Ce site est optimisé pour une résolution "+correctwidth+"x"+correctheight+".
Votre résolution actuelle est "+screen.width+"x"+screen.height+".

") //--> 

****************************************************************************
This translates as follows:
This site is optimised for a resolution "+correctwidth+"x"+correctheight+". Your
current resolution is "+screen.width+"x"+screen.height+".

The source code of the page seems to check that the screen resolution is exactly
800x600 and otherwise rejects with the above message!

var correctwidth=800
var correctheight=600
if (screen.width!=correctwidth||screen.height!=correctheight)
document.write("<B><UL>Ce site est optimis&eacute pour une r&eacute;solution
"+correctwidth+"x"+correctheight+". Votre  r&eacute;solution actuelle est
"+screen.width+"x"+screen.height+".</UL></B>")
//-->

This site displays fine on the same computer in Konqueror 2.2.1 

The full source of the page is as below:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0//EN">
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<meta http-equiv="Content-Language" content="fr">
<title>Bienvenue à l'Opéra de Nice</title>
<meta name="Description" content="l'Opéra de Nice vu par Thierry RUSSO ténor
titulaire à l'Opéra mais aussi webmaster. Un site superbement bien réalisé, avec
toute la saison lyrique, symphonique et la saison de Ballet.">
<meta name="Keywords" content=" operas, theatres lyriques,danse classique, 
chanteurs lyriques, artistes lyriques, musique classique, concerts symphoniques,
ville de nice, cote d'azur, tenors">
<meta name="Author" content="thierry russo">
<meta name="Reply-to" content="thierry.russo@opera-de-nice.com">
<meta name="Identifier-URL" content="http://www.opera-de-nice.com">
<meta name="Copyright" content="thierry russo">
<meta name="Revisit-after" content="7 days">
<meta name="Robots" content="index,follow">
<!-- META TAGS GENERES PAR WWW.ACTIREF.COM //->
</head>
<script language="JavaScript1.2">
<!--
var correctwidth=800
var correctheight=600
if (screen.width!=correctwidth||screen.height!=correctheight)
document.write("<B><UL>Ce site est optimis&eacute pour une r&eacute;solution
"+correctwidth+"x"+correctheight+". Votre  r&eacute;solution actuelle est
"+screen.width+"x"+screen.height+".</UL></B>")
//-->
</script>
<frameset rows="83,443*" cols="*" border="0" frame="0" frameborder="NO"
framespacing="0" bordercolor="#FFCC33"> <frame src="banniere2.htm" name="haut"
scrolling="no" marginwidth="0"
     marginheight="0" border="0" frame="0" frameborder="NO" noresize>
<frameset rows="*" cols="166,546*" borde="0" frame="0" frameborder="NO"
border="0" framespacing="0"> <frame name="gauche" scrolling="no"
         marginwidth="0" marginheight="0" border="0" frame="0" frameborder="NO"
src="menu2.htm" noresize>
<frame src="milieu5.htm" name="milieu" noresize marginwidth="0"
         marginheight="0" border="0" frame="0" frameborder="NO">
</frameset>
<noframes> <body bgcolor="white" text="black" link="blue" vlink="purple"
alink="red" onLoad="alert('Bienvenue à l\'Opéra de Nice - Appuyez sur F11 pour
lire tous les menus... Bon voyage! Thierry RUSSO')">
</body>
</noframes> </frameset>
</html>




Reproducible: Always
Steps to Reproduce:
1. Load URL:http://www.opera-de-nice.com
2.
3.

Actual Results:  Instead of normal site display I get an error message:
***************************************************************************

Ce site est optimisé pour une résolution "+correctwidth+"x"+correctheight+".
Votre résolution actuelle est "+screen.width+"x"+screen.height+".

") //--> 

****************************************************************************
This translates as follows:
This site is optimised for a resolution "+correctwidth+"x"+correctheight+". Your
current resolution is "+screen.width+"x"+screen.height+".

Expected Results:  A page full of graphics etc.

The source code of the page seems to check that the screen resolution is exactly
800x600 and otherwise rejects with the above message!

var correctwidth=800
var correctheight=600
if (screen.width!=correctwidth||screen.height!=correctheight)
document.write("<B><UL>Ce site est optimis&eacute pour une r&eacute;solution
"+correctwidth+"x"+correctheight+". Votre  r&eacute;solution actuelle est
"+screen.width+"x"+screen.height+".</UL></B>")
//-->

This site displays fine on the same computer in Konqueror 2.2.1 


The full source of the page is as below:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0//EN">
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<meta http-equiv="Content-Language" content="fr">
<title>Bienvenue à l'Opéra de Nice</title>
<meta name="Description" content="l'Opéra de Nice vu par Thierry RUSSO ténor
titulaire à l'Opéra mais aussi webmaster. Un site superbement bien réalisé, avec
toute la saison lyrique, symphonique et la saison de Ballet.">
<meta name="Keywords" content=" operas, theatres lyriques,danse classique, 
chanteurs lyriques, artistes lyriques, musique classique, concerts symphoniques,
ville de nice, cote d'azur, tenors">
<meta name="Author" content="thierry russo">
<meta name="Reply-to" content="thierry.russo@opera-de-nice.com">
<meta name="Identifier-URL" content="http://www.opera-de-nice.com">
<meta name="Copyright" content="thierry russo">
<meta name="Revisit-after" content="7 days">
<meta name="Robots" content="index,follow">
<!-- META TAGS GENERES PAR WWW.ACTIREF.COM //->
</head>
<script language="JavaScript1.2">
<!--
var correctwidth=800
var correctheight=600
if (screen.width!=correctwidth||screen.height!=correctheight)
document.write("<B><UL>Ce site est optimis&eacute pour une r&eacute;solution
"+correctwidth+"x"+correctheight+". Votre  r&eacute;solution actuelle est
"+screen.width+"x"+screen.height+".</UL></B>")
//-->
</script>
<frameset rows="83,443*" cols="*" border="0" frame="0" frameborder="NO"
framespacing="0" bordercolor="#FFCC33"> <frame src="banniere2.htm" name="haut"
scrolling="no" marginwidth="0"
     marginheight="0" border="0" frame="0" frameborder="NO" noresize>
<frameset rows="*" cols="166,546*" borde="0" frame="0" frameborder="NO"
border="0" framespacing="0"> <frame name="gauche" scrolling="no"
         marginwidth="0" marginheight="0" border="0" frame="0" frameborder="NO"
src="menu2.htm" noresize>
<frame src="milieu5.htm" name="milieu" noresize marginwidth="0"
         marginheight="0" border="0" frame="0" frameborder="NO">
</frameset>
<noframes> <body bgcolor="white" text="black" link="blue" vlink="purple"
alink="red" onLoad="alert('Bienvenue à l\'Opéra de Nice - Appuyez sur F11 pour
lire tous les menus... Bon voyage! Thierry RUSSO')">
</body>
</noframes> </frameset>
</html>
(Reporter)

Comment 1

17 years ago
Site does display properly on Netscape 6 =Mozilla/5.0 (Windows; U; Win98; m18)
Gecko/20001106 Netscape6/6.0

Does display properly on IE 5.50.4134.0600IS

Does display properly on opera 6.0 Build 999 Platform Win32 System Windows 98

Does *not* display on Mozilla 0.9.6 for windows.

Comment 2

17 years ago
The problem is in their comment.

<!-- META TAGS GENERES PAR WWW.ACTIREF.COM //->
</head>
<script language="JavaScript1.2">
<!--
var correctwidth=800
var correctheight=600
if (screen.width!=correctwidth||screen.height!=correctheight)
document.write("<B><UL>Ce site est optimis&eacute pour une r&eacute;solution
"+correctwidth+"x"+correctheight+". Votre  r&eacute;solution actuelle est
"+screen.width+"x"+screen.height+".</UL></B>")
//-->
</script>

If I were them, I would remove that bit of code and replace it with this:

<!-- META TAGS GENERES PAR WWW.ACTIREF.COM -->
</head>
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
Summary: Nice Opera site does not display in Mozilla 0.9.4 (shows fine in Konquerur 2.1.1) → opera-de-nice.com - does not display in Mozilla 0.9.4 (shows fine in Konquerur 2.1.1)
Whiteboard: [SYNTAX-HTML]

Comment 3

17 years ago
But they probably want that code for whatever reason, so this should do also
(add an extra hyphen after the //) 

<!-- META TAGS GENERES PAR WWW.ACTIREF.COM //-->
</head>
<script language="JavaScript1.2">
<!--
var correctwidth=800
var correctheight=600
if (screen.width!=correctwidth||screen.height!=correctheight)
document.write("<B><UL>Ce site est optimis&eacute pour une r&eacute;solution
"+correctwidth+"x"+correctheight+". Votre  r&eacute;solution actuelle est
"+screen.width+"x"+screen.height+".</UL></B>")
//-->
</script>

(Assignee)

Comment 4

17 years ago
Contact info : thierry.russo@opera-de-nice.com

WFM on Netscape 6.2, Moz 096 (win2k, Linux), also on an old Mac version of Moz
20010505 !

Caillon : where exactly do you find this "<!-- META TAGS GENERES PAR
WWW.ACTIREF.COM //-->" line ? (Which URL ?)
(Reporter)

Comment 5

17 years ago
Hi

testing today on Mozilla 0.9.6 on Windows 98 this site displays properly. 

The source code for the page is now as below (the HTML causing the problem seems
to have been removed):
<html>
<head>
<title>Untitled Document</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
</head>
<frameset rows="83,*" cols="*" frameborder="NO" border="0" framespacing="0">
<frame name="haut" scrolling="NO" src="banniere2.htm" marginwidth="0"
marginheight="0" frameborder="NO" noresize >
<frameset cols="166,*" rows="*" border="0" framespacing="0" frameborder="NO">
<frame src="menu2.htm" marginwidth="0" marginheight="0" frameborder="NO"
name="menu" scrolling="NO" noresize>
<frame name="milieu" src="milieu5.htm" frameborder="NO" marginwidth="0"
marginheight="0" scrolling="AUTO">
</frameset>
</frameset>
<noframes>
<body bgcolor="#FFFFFF" text="#000000">
</body>
</noframes> </html>

Bug can be closed as solved?
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 6

17 years ago
Tristan: looks like they updated the site.  It is changed since I looked at it
and like the reporter says, it does indeed now work.

Marking verified fixed on linux 2001113021.
Status: RESOLVED → VERIFIED
New Component
Component: Europe: West → French
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.