[Clock] Double-tapping "Save" on the Alarm Edit screen results in undeletable alarms

RESOLVED FIXED in 2.2 S5 (6feb)

Status

defect
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: mcav, Assigned: mcav)

Tracking

unspecified
2.2 S5 (6feb)
x86
macOS

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 fixed, b2g-master verified)

Details

Attachments

(4 attachments)

(Assignee)

Description

4 years ago
Double-tapping "Save" on the Alarm Edit screen results in undeletable alarms; more specifically, multiple alarms are created, but the alarm list gets out of date.

Bug 1080295 exhibits similar symptoms, but the cause is different.
(Assignee)

Comment 1

4 years ago
Requesting blocking-b2g for this because Bug 1080295 was also blocking-b2g for 2.2+, and the reproduction steps for this bug are similar (but not identical), with a similar outcome.
Assignee: nobody → m
blocking-b2g: --- → 2.2?
(Assignee)

Comment 3

4 years ago
Comment on attachment 8556571 [details] [review]
[PullReq] mcav:clock-double-tap-alarm-edit to mozilla-b2g:master

This is a simple fix for the problem and should exhibit no ill side effects. Fixed when tested on a Flame. Automated tests for alarm_edit_view are still disabled per bug 1033213, which will be addressed as soon as I get more bandwidth to work on Clock.
Attachment #8556571 - Flags: review?(mmedeiros)
Comment on attachment 8556571 [details] [review]
[PullReq] mcav:clock-double-tap-alarm-edit to mozilla-b2g:master

LGTM.
Attachment #8556571 - Flags: review?(mmedeiros) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
(Assignee)

Comment 5

4 years ago
master: https://github.com/mozilla-b2g/gaia/commit/dfd3d3d1cdd91691403977db654b498b80788574
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

4 years ago
Comment on attachment 8556571 [details] [review]
[PullReq] mcav:clock-double-tap-alarm-edit to mozilla-b2g:master

[Approval Request Comment]

[Bug caused by] (feature/regressing bug #):

  None, always present.

[User impact] if declined:

  If users double-tap on the Edit button, the list of alarms will include a non-deletable "dummy" alarm.

[Testing completed]:

  Manual verification on a Flame.

[Risk to taking this patch] (and alternatives if risky):

  Very low risk.

[String changes made]:

  None.
Attachment #8556571 - Flags: approval-gaia-v2.2?
blocking-b2g: 2.2? → 2.2+
Attachment #8556571 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
This bug has been verified as "pass" on latest Nightly build of Flame master by the STR in Comment 0.

Actual results: Creating some alarms and double-tapping "Done" icon on the alarm editing screen, it doesn't result in undeletable alarms.
See attachment: verified_master.3gp
Reproduce rate: 0/10

Device: Flame master (Verified)
Build ID               20150702160209
Gaia Revision          722028715a56a03f327e2e70f2c32dcb6d819d4c
Gaia Date              2015-07-02 08:51:28
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/2f25351c5b05
Gecko Version          42.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150702.193535
Firmware Date          Thu Jul  2 19:35:46 EDT 2015
Bootloader             L1TC000118D0
Posted file logcat_1434.txt
Hi Marcus,

    This bug is set as 'fixed' in comment 7, but it still can be reproduced on latest Flame v2.2 by the STR of comment 0 (please see video and log).
    Could you help to check if it landed on v2.2 successfully?

Thank you very much.
Flags: needinfo?(m)
QA Whiteboard: [MGSEI-Triage+]
(Assignee)

Updated

4 years ago
Flags: needinfo?(m)
You need to log in before you can comment on or make changes to this bug.