Closed Bug 1124977 Opened 6 years ago Closed 6 years ago

[FFOS2.0][Woodduck][3rd APK][ConnectA2 V017h] ConnectA2 no way to change phone number during register before receive confirm code.

Categories

(Tech Evangelism Graveyard :: Preinstalled B2G Apps, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: sync-1, Unassigned)

References

Details

PR Reporter:邢艳
 contact:0752-2639551(61551)
 		
 
  DEFECT DESCRIPTION:
 >ConnectA2 no way to change phone number during register before receive confirm code.
  REPRODUCING PROCEDURES:
 1.Enter connectA2 and register with a phone number, but there is no way to change phone number during register before receive confirm code.
 PS:Once user input a wrong phone number, can't use connectA2 unless reset phone.
 
 中文:如果用户输错了验证的手机号码,会进入等待验证码界面并且无法退出去修改号码,重启手机也无法恢复,只能恢复出厂设置。
 
  EXPECTED BEHAVIOUR:
 >User should can back to change phone number during register.
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
Component: Gaia → Preinstalled B2G Apps
Product: Firefox OS → Tech Evangelism
Blocks: Woodduck
It is necessary this behaviour in reference devices, because the GC closes the App when you go to read the SMS pass code.

If the number format is not correct, the App doesn't send you to confirmation screen. If you want to change the number (not very usual for a normal user) you can reinstall the App.

You can always reinstall the App as workaround.

Juanma
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.