[FFOS7715 v2.1] STK confirm message(icc-view) will never show on top of callscreen, this will block the case 27.22.4.13.1-SEQ 1.7 of 3GPP-31.124

RESOLVED DUPLICATE of bug 1091483

Status

Firefox OS
Gaia::System
--
major
RESOLVED DUPLICATE of bug 1091483
4 years ago
3 years ago

People

(Reporter: helloarvin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sprd391399])

(Reporter)

Description

4 years ago
Reproduce steps: Run the case 3GPP-31.124-27.22.4.13.1-SEQ 1.7 

Expected Sequence 1.7 (SET UP CALL, putting all other calls on hold, call hold is not allowed)
ME is busy on a call. The USS shall be configured to not allow Call Hold.

Step   Direction             MESSAGE / Action 
 1    UICC --> ME    PROACTIVE COMMAND PENDING: SET UP CALL 1.4.1
 2    ME --> UICC                 FETCH
 3    UICC --> ME    PROACTIVE COMMAND: SET UP CALL 1.4.1
 4    ME --> USER    ME displays "On hold" during the user confirmation phase

Results:
The "On hold" message cannot display on the topmost so that the case will be blocked on the step 4 and the stk confirm message will be hidden if we pressed home button.

Reproduce rate: 100%
(Reporter)

Comment 1

4 years ago
Reproduced steps without test instrument:
1) Set up a call via sim 1 first(e.g. dial 10086) to keep ME busy on a call;
2) open terminal:
   > adb shell
   > radiooptions_sp 11 "+SPUSATSETUPCALL:D01D81030110028202818385074F6E20686F6C648609911032042143651C2C" "OK"


The reason for this should be the different z-index config[1,2] and of course it's reasonable that we should ensure the display priority of callscreen(attention type) is higher than stk message(icc-view). However, we might think it over and then do something to no longer block the USAT case.

The most simplest answer is just to improve the z-index of icc-view but this would cause a serious problem: the callscreen will display on the behind of icc-view when the new incoming call arrived.

Hence, my opinion on this is a workaround to close all attention window if the callscreen window is the topmost one currently. The solution is just like the effect 'press the home button first' and user can resume the callscreen via 'Tap to show' on notifications page.

I would like to know are there any better solutions on the sceranio?

Many thanks for your attention.


[1] https://github.com/mozilla-b2g/gaia/blob/v2.1/apps/system/index.html#L1180
[2] https://github.com/mozilla-b2g/gaia/blob/v2.1/apps/system/style/zindex.css#L89-91
(Reporter)

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1091483
You need to log in before you can comment on or make changes to this bug.