Closed Bug 1125043 Opened 8 years ago Closed 3 years ago

Download notifications are cleared from Android notification bar after you enter/exit Guest Mode

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(firefox35 unaffected, firefox36 unaffected, firefox37 affected, firefox38 affected, fennec+)

RESOLVED INVALID
Tracking Status
firefox35 --- unaffected
firefox36 --- unaffected
firefox37 --- affected
firefox38 --- affected
fennec + ---

People

(Reporter: TeoVermesan, Unassigned, Mentored)

References

Details

(Keywords: regression, Whiteboard: [lang=js])

Attachments

(1 file)

Device: Nexus 5 (Android 5.0.1)
Steps to reproduce:
1. Open gmail.com
2. Go to Menu -> Page -> Save as PDF
3. Enter guest mode
4. Exit guest mode

Expected results:
- After entering guest mode, the download notification appears near the Guest browsing notification.
- After exiting guest mode, the download notification is still displayed in the android notification bar.

Actual results:
- After entering guest mode, only the Guest browsing notification is displayed.
- After exiting guest mode, the download notification is not displayed anymore in the android notification bar.

Note:
-not reproducible on 35 Firefox and 36 Beta 2
-reproducible on latest 37 Aurora and 38 Nightly
Flags: needinfo?(teodora.vermesan)
I think it's most probably from bug Bug 901360 - Convert to Downloads.jsm
Blocks: 901360
Can confirm:
good build:
2014-12-16
bad build:
2014-12-17
pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b836016d82b5&tochange=b7eb1ce0237d
Flags: needinfo?(teodora.vermesan)
tracking-fennec: --- → ?
Assignee: nobody → wjohnston
tracking-fennec: ? → +
Maybe Margaret's army can take this one too
Assignee: wjohnston → nobody
I'm not sure what's causing this, so this would require some investigation, but I could help anyone who's willing to dig into it.
Mentor: margaret.leibovic
Whiteboard: [lang=js]

Hello, the 'Guest Mode' option is now deleted from the actual version of Nightly/Beta as a result of bug 1536866. Due to that, I'll close this issue as Invalid, thanks.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INVALID
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.