Calling Object.prototype.toString on revoked proxies causes segmentation fault

RESOLVED DUPLICATE of bug 1100936

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 1100936
3 years ago
3 years ago

People

(Reporter: ziyunfei, Unassigned)

Tracking

(Blocks: 1 bug)

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
js> let {proxy, revoke} = Proxy.revocable({}, {})
js> revoke()
js> ({}).toString.call(proxy)
[1]    33488 bus error  js
Blocks: 1088640

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1100936
This calls an other trap.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1100936
You need to log in before you can comment on or make changes to this bug.