not asked for password when ftp://user@host through a proxy server

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
18 years ago
5 years ago

People

(Reporter: ed, Assigned: badami)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

Reporter

Description

18 years ago
The network here is configured to use a Squid proxy on port 80 for ftp and http.
If I enter a URL of the form ftp://user@host, I get the following displayed in
the browser window:

ERROR
The requested URL could not be retrieved

An FTP authentication failure occurred while trying to retrieve the URL:
ftp://user@host/

Squid sent the following FTP command:

PASS 

and then received this reply

Login incorrect.

With proxy support disabled, I get a dialog asking for my password. This should
also happen when the proxy is enabled.
Status: UNCONFIRMED → NEW
Ever confirmed: true
ftp proxies don't involve ftp

-> http for triage.

Maybe http with a username should always prompt for a password? We're going to
need it anyway, in all cases, I think
Assignee: bbaetz → darin
Component: Networking: FTP → Networking: HTTP
QA Contact: benc → tever

Comment 2

18 years ago
no, we avoid sending user:pass encoded in URLs unless the server responds with a
401.  this is done because we don't know what challenge the server will send. 
we shouldn't just assume that basic auth is appropriate since it sends the
user:pass in pseudo-plaintext.

my guess is that squid is failing to send a 401 in this case.

tever: can you try to reproduce this bug using your squid proxy?  thx!
Keywords: qawanted

Comment 3

18 years ago
reporter: a http log would also be very helpful. to generate one you'll need to
do the following:

1) open a DOS prompt
2) type: set NSPR_LOG_MODULES=nsHttp:5
3) type: set NSPR_LOG_FILE=c:\http.log
4) type: cd \path\to\mozilla-nightly-build
5) type: .\mozilla.exe
6) reproduce the problem
7) attach c:\http.log to this bug report

thx in advance!

Comment 4

18 years ago
-> badami for investigation
Assignee: darin → badami
Reporter

Comment 5

18 years ago
This is the log requested. Sorry I took so long.
Assignee

Comment 6

18 years ago
reporter:
Can u please try with a nightly build - preferably tomorrow's. 
There have been a number of fixes in the auth prompting area that this may have
been fixed as a result of those fixes.
Reporter

Comment 7

18 years ago
Just tried it with build 2002021403, no difference.
Assignee

Comment 8

18 years ago
Is there a URL I can test against ?

Comment 9

18 years ago
WFM Build ID: 2002032003 (0.9.9+) Windows 98.

Sample URI:       ftp://ftp@ftp.mozilla.org

(Type anything as a password.)
Reporter

Comment 10

18 years ago
I just downloaded 2002032003. ftp://ftp@ftp.mozilla.org doesn't ask me for a
password. Still get the errors on other sites. I guess for a site try
ftp://username@attila.stevens-tech.edu. Any username will show the problem. I'm
not 100% positive though that the server is visibile outside of campus.

Comment 11

18 years ago
Yeah, this problem is definitely limited to connections through proxies.

Old Summary: Mozilla doesn't ask for a password for ftp://user@host urls when
using a proxy

New Summary: not asked for password when ftp://user@host through a proxy server

Summary: Mozilla doesn't ask for a password for ftp://user@host urls when using a proxy → not asked for password when ftp://user@host through a proxy server
Assignee

Comment 12

18 years ago
The squid proxy is sending us back a 403 Forbidden as opposed to a 401
Unauthorized response. 
Hence we display the forbidden message as opposed to prompting for username/passwd.
0[8c2cf0]: http request [
0[8c2cf0]:   GET ftp://username@attila.stevens-tech.edu/ HTTP/1.1
0[8c2cf0]:   Host: attila.stevens-tech.edu
0[8c2cf0]:   User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.9+)
Gecko/20020320
0[8c2cf0]:   Accept:
text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,video/x-mng,image/png,image/jpeg,image/gif;q=0.2,text/css,*/*;q=0.1
0[8c2cf0]:   Accept-Language: en-us, en;q=0.50
0[8c2cf0]:   Accept-Encoding: gzip, deflate, compress;q=0.9
0[8c2cf0]:   Accept-Charset: ISO-8859-1, utf-8;q=0.66, *;q=0.66
0[8c2cf0]:   Keep-Alive: 300
0[8c2cf0]:   Proxy-Connection: keep-alive
0[8c2cf0]:   Proxy-Authorization: Basic ************
0[8c2cf0]:   Authorization: Basic ************
0[8c2cf0]: ]

168[c98570]: http response [
168[c98570]:   HTTP/1.0 403 Forbidden
168[c98570]:   Server: Squid/2.4.STABLE1
168[c98570]:   Mime-Version: 1.0
168[c98570]:   Date: Thu, 21 Mar 2002 07:53:15 GMT
168[c98570]:   Content-Type: text/html
168[c98570]:   Content-Length: 816
168[c98570]:   Expires: Thu, 21 Mar 2002 07:53:15 GMT
168[c98570]:   X-Squid-Error: ERR_FTP_FORBIDDEN 0
168[c98570]:   X-Cache: MISS from unagi.nscp.aoltw.net
168[c98570]:   Proxy-Connection: keep-alive
168[c98570]: ]
Not sure that we have anything to fix here.
Assignee

Comment 13

18 years ago
IE behaves similarly too.
Assignee

Comment 14

18 years ago
Marking as invalid based on comment 12 and comment 13.
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED

Comment 15

18 years ago
vinay: we should probably file a squid bug on this... any chance you could poke
the squid developers?
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.