[10.10] text-indent: -9999999px; freezes browser

RESOLVED DUPLICATE of bug 1123019

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 1123019
3 years ago
3 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

38 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150123004028

Steps to reproduce:

Only reproduced on Firefox 35 and 37 on OSX

1. Open a modal
2. Move the modal, scroll the window or interact with it
3. Firefox freezes

Exampel: 
http://jsfiddle.net/g8sj816f/

Code to reproduce: 

<!DOCTYPE html>
<html>
<head>
  <meta http-equiv="content-type" content="text/html; charset=UTF-8">
  <title> Firefox freezes </title>
  
      <script type='text/javascript' src="http://code.jquery.com/jquery-2.1.3.min.js"></script>
      <script type='text/javascript' src="http://code.jquery.com/ui/1.11.2/jquery-ui.min.js"></script>
    
<style type='text/css'>
    html, body {
    height: 150%;
}
.modal {
    display: none;
    background: #ccc;
}
.ui-dialog-titlebar {
    background: #666;
}

/* button text element from jquery-ui.css */
.ui-button .ui-button-text {
	display: block; /* Line 155*/
}
.ui-button-icon-only .ui-button-text,
.ui-button-icons-only .ui-button-text {
	text-indent: -9999999px; /* Line 165*/
}

</style>
  
<script type='text/javascript'>//<![CDATA[ 
window.onload=function(){
$( ".modal" ).dialog({
    autoOpen: false,
    height: "auto",
    width: 570,
    modal: true,
    resizable: false
});

$("a").on("click", function(e){
    e.preventDefault();
    $( ".modal:hidden:first" ).dialog( "open" );
});
}//]]>  

</script>

</head>
<body>

  <a href="openModal">Open modal</a>
  <div class="modal"></div>
  
</body>

</html>


Actual results:

A css hack used in jQuery UI, amongst others can cause browser to freeze for up to over a minute.


Expected results:

Browser should not freeze.

Comment 1

3 years ago
WFM with FF35/38 on Win 7.

Could you test with a fresh profile, please.
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(bugzilla)
I can not reproduce a freeze with Firefox35 on OSX10.9
(Reporter)

Comment 3

3 years ago
Confirmed with a fresh profile on FF35.0.1 and OSX 10.10.1

Most notable when moving the modal window a few times.

More complexity in the page gives longer freeze times.
Flags: needinfo?(bugzilla)

Comment 4

3 years ago
Maybe issue only with OSX 10.10.?

Paul, do you know someone from QA with OSX 10.10 who can test?
Flags: needinfo?(paul.silaghi)
Confirmed a 2-3 seconds freeze everytime I move the modal dialog and scroll, 38.0a1 (2015-01-27) OS X 10.10
Status: UNCONFIRMED → NEW
Component: Untriaged → Untriaged
Ever confirmed: true
Flags: needinfo?(paul.silaghi)
Product: Firefox → Core
Summary: text-indent: -9999999px; freezes browser → [10.10] text-indent: -9999999px; freezes browser
Version: 37 Branch → 38 Branch
Component: Untriaged → Layout
Can someone who can reproduce this please get a sample using Activity Monitor?
Created attachment 8556452 [details]
Sample of Nightly.txt
Thanks.  That's all in the depths of CoreGraphics painting the (presumably huge in this case) outline...
Component: Layout → Graphics
I wonder if this will turn out to be the same as bug 1123019?
cc'ing Markus, who is looking at that.
Sure looks identical...
Depends on: 1123019
I've tested this page with my patches from bug 1123019 and confirmed that they fix the problem.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1123019
You need to log in before you can comment on or make changes to this bug.