Google Sheets breaks UI on cell edit when navigating during cell formula input

RESOLVED INCOMPLETE
(NeedInfo from)

Status

()

Core
Graphics
RESOLVED INCOMPLETE
3 years ago
2 years ago

People

(Reporter: Sid, Unassigned, NeedInfo)

Tracking

({qawanted, regression})

38 Branch
x86_64
Linux
qawanted, regression
Points:
---

Firefox Tracking Flags

(firefox37 unaffected, firefox38+ wontfix)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8553739 [details]
Screenshot from 2015-01-23 20:13:38.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0
Build ID: 20150122030202

Steps to reproduce:

1. Open Google Sheets
2. Create a new sheet
3. Enter any numerical data in cells A1 and A2.
4. In Cell A3, attempt to input formula "=A1+A2".
5. After typing "=" sign, formula mode will get activated. Navigate to cell A1 using arrow keys.


Actual results:

As soon as arrow keys are pressed, the UI breaks, the entire worksheet becomes black and multiple cells receive the selection box.


Expected results:

Formula should have been updated with address of cell A1 without any breakage of sheet UI.

Comment 1

3 years ago
WFM with FF35 on Win 7.
That smells graphics issue.  Could you paste the section "graphics" from about:support, please.
Component: Untriaged → Graphics
Flags: needinfo?(sks3286)
Product: Firefox → Core
Version: Firefox 38 → 35 Branch

Updated

3 years ago
Version: 35 Branch → 38 Branch
(Reporter)

Comment 2

3 years ago
Loic I'm talking of the Nightly build here. This is a regression. It was working sometime ago (like maybe a couple of months). Today when I logged into one of my sheets, its giving this issue. Anyway, here's the graphics section from about:support.

Graphics
Adapter Description	       Intel Open Source Technology Center -- Mesa DRI Intel(R) Ironlake Mobile
Device ID	               Mesa DRI Intel(R) Ironlake Mobile
Driver Version	               2.1 Mesa 10.3.2
GPU Accelerated Windows	       0/1 Basic (OMTC)
Vendor ID	               Intel Open Source Technology Center
WebGL Renderer	               Intel Open Source Technology Center -- Mesa DRI Intel(R) Ironlake Mobile
windowLayerManagerRemote       true
AzureCanvasBackend	       cairo
AzureContentBackend	       cairo
AzureFallbackCanvasBackend     none
AzureSkiaAccelerated	       0
Flags: needinfo?(sks3286)

Comment 3

3 years ago
Yeah, I know it's Nightly. :)
After my message, I tested with FF38: same behaviour as FF35, WFM on Win 7.

If you think it regressed somewhere, you can use the tool mozregression (see http://mozilla.github.io/mozregression/ for details) to find the pushlog (no need to bisect).
(Reporter)

Comment 4

3 years ago
Unfortunately I have no idea when this regressed. It could have been as far back as a month or two maybe. Let me try something tomorrow morning

Comment 5

3 years ago
mozreg is designed for that, it uses dichotomy so it's pretty fast to find the regression range. If you don't know the start date and you think it was good 6 m or 12 m, just run --good=2014-01-01 or --good=2014-06-01 and you're fine.
(Reporter)

Comment 6

3 years ago
This is very weird. I ran the mozreg tool and none of the builds turned up bad so I retried the steps in the installed build and it worked fine this time. The issue seems to have disappeared. I'll continue testing and reopen the bug/create a new one if the issue comes up again. Marking it as WORKSFORME for now

Thanks for your time Loic
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

3 years ago
(In reply to Sid from comment #6)
> This is very weird. I ran the mozreg tool and none of the builds turned up
> bad so I retried the steps in the installed build and it worked fine this
> time. The issue seems to have disappeared. I'll continue testing and reopen
> the bug/create a new one if the issue comes up again. Marking it as
> WORKSFORME for now
> 
> Thanks for your time Loic

Ooops spoke too soon... Mozreg was still running. Last build crashed. So the issue is still there it seems. And the installed build I mentioned was accidentally the FF production version. Reopening this. Sorry for the mess.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 9

3 years ago
It seems to be a fresh regression in FF38.
Status: UNCONFIRMED → NEW
status-firefox37: --- → unaffected
tracking-firefox38: --- → ?
Ever confirmed: true
Keywords: regression
(Reporter)

Comment 10

3 years ago
and by the looks of it, Linux specific?

Comment 11

3 years ago
On my side, WFM on Win 7.
(Reporter)

Comment 12

3 years ago
Checked with latest nightly bits on Ubuntu 14.10 again. Issue persists
Milan - can you or someone from Graphics take a look at the regression range in comment 8 and see if there's an obvious bug that might have caused this?
Flags: needinfo?(milan)
Loic, what's your configuration?  I don't see this problem on 14.04
Flags: needinfo?(milan) → needinfo?(epinal99-bugzilla2)

Comment 15

3 years ago
It's not Linux, but Win 7 x64. And I can't reproduce the issue.

Date du pilote	1-29-2014
Date du pilote (GPU 2)	9-13-2014
Description de la carte	Intel(R) HD Graphics 3000
Description de la carte (GPU 2)	NVIDIA GeForce GT 550M
Direct2D activé	true
DirectWrite activé	true (6.2.9200.16571)
Fenêtres avec accélération graphique	1/1 Direct3D 11 (OMTC)
GPU 2 actif	false
ID du périphérique	0x0116
ID du périphérique (GPU 2)	0x0df6
ID du sous-système	17121043
ID du sous-système (GPU 2)	17121043
ID du vendeur	0x8086
ID du vendeur (GPU 2)	0x10de
Paramètres ClearType	Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50
Pilote de la carte (GPU 2)	nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Pilotes de la carte	igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
RAM de la carte	Unknown
RAM de la carte (GPU 2)	2048
Rendu WebGL	Google Inc. -- ANGLE (Intel(R) HD Graphics 3000 Direct3D9Ex vs_3_0 ps_3_0)
Version du pilote	9.17.10.3347
Version du pilote (GPU 2)	9.18.13.4411
windowLayerManagerRemote	true
AzureCanvasBackend	direct2d
AzureContentBackend	direct2d
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0
Flags: needinfo?(epinal99-bugzilla2)
qawanted - can we reproduce locally on Linux?  WFM with Ubunty 14.04 nightly.
Keywords: qawanted
Whiteboard: [gfx-noted]
tracking-firefox38: ? → +
Sid, can you get a mozregression range that includes the inbound builds? mozregression should automatically continue to do the inbound builds after it does the central builds.
Flags: needinfo?(sks3286)
Comment hidden (off-topic)
Comment hidden (off-topic)
Sid, do you still see this bug? I am running Linux and I haven't seen it.
It seems not common as we didn't get any duplicate or an answer from sid. I am going to untrack it then.
status-firefox38: --- → wontfix
(In reply to Jeff Muizelaar [:jrmuizel] from comment #17)
> Sid, can you get a mozregression range that includes the inbound builds?
> mozregression should automatically continue to do the inbound builds after
> it does the central builds.

It's too late for that now and we've not heard back from the reporter in several months. Therefore I am closing this bug as incomplete. Please reopen the bug report if any new information comes to light and the bug still reproduces with current Firefox versions.
Status: NEW → RESOLVED
Last Resolved: 3 years ago2 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.