mozilla::ipc::FatalError crash in mozilla::jsipc::PJavaScriptChild::Read

RESOLVED WORKSFORME

Status

()

Core
IPC
P3
critical
RESOLVED WORKSFORME
3 years ago
a year ago

People

(Reporter: alex_mayorga, Assigned: billm)

Tracking

({crash, meta, topcrash})

Trunk
All
Windows NT
crash, meta, topcrash
Points:
---

Firefox Tracking Flags

(e10s+, firefox38 affected)

Details

(Whiteboard: [e10s-45-uplift], crash signature)

(Reporter)

Description

3 years ago
This bug was filed from the Socorro interface and is 
report bp-8ead4ae8-bdc2-470c-b9fd-1d6982150123.
=============================================================
(Reporter)

Updated

3 years ago
status-firefox38: --- → affected
Version: 37 Branch → Trunk

Updated

2 years ago
Crash Signature: [@ mozalloc_abort(char const* const) | NS_DebugBreak | mozilla::ipc::FatalError(char const*, char const*, void*, bool) | mozilla::jsipc::PJavaScriptChild::Read(mozilla::jsipc::JSVariant*, IPC::Message const*, void**)] → [@ mozalloc_abort(char const* const) | NS_DebugBreak | mozilla::ipc::FatalError(char const*, char const*, void*, bool) | mozilla::jsipc::PJavaScriptChild::Read(mozilla::jsipc::JSVariant*, IPC::Message const*, void**)] [@ mozalloc_abort | NS_DebugB…
There seem to be a decent number of these crashes... although they seem to have gotten substantially more common in nightly around 2015-12-14:

https://crash-stats.mozilla.com/signature/?product=Firefox&release_channel=nightly&date=%3E%3D2015-08-01&signature=mozalloc_abort+|+NS_DebugBreak+|+mozilla%3A%3Aipc%3A%3AFatalError+|+mozilla%3A%3Ajsipc%3A%3APJavaScriptChild%3A%3ARead#aggregations

It's not clear to me whether it's worth separating the spike on December 14 into a separate bug -- or even how we distinguish different sorts of problems in these crash reports.
Component: General → General
Product: Firefox → Core
Component: General → XPConnect
Keywords: topcrash
Component: XPConnect → IPC
Bug 1210821 comment #4 may be relevant.  I'm not sure if it makes much difference whether the PJavaScript{Child,Parent}::Read -> FatalError call is about an unexpected end of message or a bad enum discriminant (which are the two calls I see there) — either way, there's a sync IPC call that got a response not of the expected type, meaning that the IPC message layer got message ordering wrong and violated the IPDL layer's type safety.

Trying to find the cause beyond that from crash data may not be possible; I don't know that the code representing the root cause would still be on a stack at that point.

Updated

2 years ago
Summary: crash in mozalloc_abort(char const* const) | NS_DebugBreak | mozilla::ipc::FatalError(char const*, char const*, void*, bool) | mozilla::jsipc::PJavaScriptChild::Read(mozilla::jsipc::JSVariant*, IPC::Message const*, void**) → mozilla::ipc::FatalError crash in mozilla::jsipc::PJavaScriptChild::Read
tracking-e10s: --- → ?
Bill, is this strictly add-on CPOW related?
Flags: needinfo?(wmccloskey)
(Assignee)

Comment 4

2 years ago
Yes, this is one of the IPC bugs I'm hoping to fix soon.
Flags: needinfo?(wmccloskey)
(Assignee)

Updated

2 years ago
tracking-e10s: ? → m8+
Whiteboard: [e10s-45-uplift]
(Assignee)

Updated

2 years ago
QA Contact: wmccloskey
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1239697
Assignee: nobody → wmccloskey
QA Contact: wmccloskey

Updated

2 years ago
Crash Signature: [@ mozalloc_abort(char const* const) | NS_DebugBreak | mozilla::ipc::FatalError(char const*, char const*, void*, bool) | mozilla::jsipc::PJavaScriptChild::Read(mozilla::jsipc::JSVariant*, IPC::Message const*, void**)] [@ mozalloc_abort | NS_DebugB… → [@ mozalloc_abort(char const* const) | NS_DebugBreak | mozilla::ipc::FatalError(char const*, char const*, void*, bool) | mozilla::jsipc::PJavaScriptChild::Read(mozilla::jsipc::JSVariant*, IPC::Message const*, void**)] [@ mozalloc_abort | NS_DebugB…
tracking-e10s: m8+ → +
Keywords: meta
Priority: -- → P1

Updated

a year ago
Priority: P1 → P3
(Reporter)

Comment 6

a year ago
¡Hola!

None of the signatures on this bug has crashes in the past week, resolving.

¡Gracias!
Alex
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.