Bug Lists: For duplicates, link to the real one

REOPENED
Unassigned

Status

()

Bugzilla
Query/Bug List
--
enhancement
REOPENED
17 years ago
8 years ago

People

(Reporter: xyzzy, Unassigned)

Tracking

(Depends on: 1 bug)

Details

(Reporter)

Description

17 years ago
When a bug list contains a duplicate bug, it would be nice to have a link to the
"real" bug instead of just the one marked as a duplicate.  This might require
chasing down a chain of duplicates until a non-duplicate is found.

The interface for this might be simply converting the result field "DUPL" to
linked  text to the "real" bug.
Target Milestone: --- → Future

Updated

15 years ago
Summary: [RFE] Bug Lists: Easy link for duplicates → Bug Lists: For duplicates, link to the real one

Comment 1

15 years ago
I don't think this is a good idea: it violates the principle that buglist points
to the bug in question. A duplicate bug *is* a real bug -- it just a "semantic
duplicate" of another; it's often important to visit a duplicate to see who was
the original reporter, what platform it was reported on, and so on.

I understand your motivation for optimizing finding the real bug, but why are
you listing and visiting duplicates in the first place?

Marking WONTFIX; please reopen if you think you have a good rationale for this.

(One perhaps "more valid" approach might be adding a "Duplicate Of" column to
buglist.cgi, but this isn't what's being proposed here)
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
bulk removing target on WONTFIX/INVALID/WORKSFORME/DUPLICATE so they'll show up
as untriaged if they get reopened.
Target Milestone: Future → ---

Comment 3

13 years ago
*** Bug 312549 has been marked as a duplicate of this bug. ***

Updated

11 years ago
Duplicate of this bug: 236037

Updated

11 years ago
Duplicate of this bug: 389497

Comment 6

11 years ago
kiko: i feel you're misinterpreting the request, however I'm willing to add a badge next to the DUPL text which is also linked to indicate that it is not going to the same place. In fact, I'll probably just make the badge link to the bug, because I'm trying to change buglists to be more like drill down, in which case most fields actually don't link to the bug.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 7

11 years ago
My suggestion in the dupe bug 312549 is have the word 'DUPE', rather than the bug number, link to the real bug. That doesn't seem to violate anything and doesn't require another column (the text might also be extended to say 'dupe of bug XXXXXX', without creating another column but at the cost of expanding the status column).

Comment 8

11 years ago
I think This bug depends on Bug 68611 getting fixed first per Comment #0.

Depends on: 68611

Updated

8 years ago
QA Contact: matty_is_a_geek → default-qa

Updated

8 years ago
Assignee: endico → query-and-buglist
You need to log in before you can comment on or make changes to this bug.