Closed Bug 1125402 Opened 6 years ago Closed 5 years ago

[Polaris] Breakdown - Implement control center dialog

Categories

(Firefox :: General, defect)

defect
Not set
normal
Points:
5

Tracking

()

RESOLVED FIXED
Iteration:
39.2 - 23 Mar

People

(Reporter: javaun, Assigned: ttaubert)

References

Details

This is an engineering breakdown to implement the UI dialog for the privacy center. This dialog would be accessible on mouse click or via ctrl+i (cmd+i OSX).
Depends on: 1125230
Flags: qe-verify-
Flags: firefox-backlog+
Good separate bugs might be:

1) Get strings into 38. We need UX to finalize the wording for the first version of the privacy center so that we can land strings early and are able to work on it in the 39.* iterations and uplift.

2) Restyle the identity panel. The basis of the privacy center will be a restyling of the current identity panel. The visual update of the permissions section should probably be included here but could also be a separate bug to keep bugs small.

3) Implement subsections. The UX mockups show an arrow on the right side of a few sections that lead to more information. UX needs to specify the desired animation and resulting subsection that will be shown. I *think* that having this be a separate bug makes sense but maybe it does not?

4) Add history section. The privacy center will have a new history section that will need to be defined in more detail by UX. It will most likely have a button as a shortcut to the "Forget about this site" functionality. It might also display the number of times you visited the current site.

5) Locationbar update. UX hinted that in order to promote the new privacy center we would need to put more emphasis on the identity part of the locationbar. The changes here can be done separate from the actual implementation of the new panel.

That list looks complete to me for a first iteration of the privacy center and should put us into a position where we can easily add new sections to it in future releases.
(In reply to Javaun Moradi [:javaun] from comment #0)
> This is an engineering breakdown to implement the UI dialog for the privacy
> center. This dialog would be accessible on mouse click or via ctrl+i (cmd+i
> OSX).

Please note that ctrl+i is used to toggle the bookmarks sidebar on Windows. I'm not sure how many use it however, and ctrl+b also toggles it.
Where is the mockup for this? Also, is this launch blocker for tracking protection?
Flags: needinfo?(jmoradi)
A lot of the design work done for privacy center was done to solve the v1 needs for TP and to make it a home, but there's also some concepts in there that may go beyond v1 for privacy center and certainly for  launch of TP. 

This is the relevant bug for launching TP bug 1135270
Flags: needinfo?(jmoradi)
(In reply to Javaun Moradi [:javaun] from comment #4)
> A lot of the design work done for privacy center was done to solve the v1
> needs for TP and to make it a home, but there's also some concepts in there
> that may go beyond v1 for privacy center and certainly for  launch of TP. 
> 
> This is the relevant bug for launching TP bug 1135270

There's also no mock on bug 1135270.
Flags: needinfo?(jmoradi)
It's a new bug that was assigned today. Mocks are already in progress and those (and a spec) are needed to close 1135270

(In reply to [:mmc] Monica Chew (please use needinfo) from comment #5)
> (In reply to Javaun Moradi [:javaun] from comment #4)
> 
> There's also no mock on bug 1135270.
Flags: needinfo?(jmoradi)
Summary: [Polaris] Breakdown - Implement privacy center dialog → [Polaris] Breakdown - Implement control center dialog
Points: --- → 5
Hardware: x86 → All
Assignee: nobody → ttaubert
Status: NEW → ASSIGNED
Iteration: --- → 39.2 - 23 Mar
Depends on: 1140774
Depends on: 1146269
Depends on: 1146272
Depends on: 1146278
Depends on: 1146282
Depends on: 1146284
Depends on: 1146287
Depends on: 1146288
Broken down.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Blocks: 1154742
Duplicate of this bug: 893355
Duplicate of this bug: 909326
You need to log in before you can comment on or make changes to this bug.