Update Notice shown every time I open Firefox Developer Edition (37.0a2)

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: gregoryplace, Unassigned)

Tracking

37 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150121004011

Steps to reproduce:

I have Firefox Developer Edition on my Mac Mini (OS X 10.10.1)
Version: 37.0a2 (2015-01-21)

Every time I open Firefox, it shows a notification that an update is available.

I have tried installing the update (multiple times), but the version does not change.


Actual results:

What Happened:
Notification is shown, but installing the update does nothing.


Expected results:

Either the notification should not appear, or there should be a real update.
(Reporter)

Updated

4 years ago
Hardware: x86 → x86_64

Comment 1

4 years ago
Follow the workaround here: http://kb.mozillazine.org/Software_Update

If that dosn't work, just reset your current profile to a new one: https://support.mozilla.org/en-US/kb/reset-firefox-to-fix-most-problems
Flags: needinfo?(gregoryplace)
(Reporter)

Comment 2

4 years ago
I just reset the profile.  As soon as it started back up again, the notification appeared again.
Flags: needinfo?(gregoryplace)

Comment 3

4 years ago
Do you see any error message about update failing in the browser console?
(Reporter)

Comment 4

4 years ago
Nope.  I just installed the update again, and as soon as I "restarted to install", it sent the notification again.  One thing to try might be to change from the auora update channel to the standard, then back.  Do you know how to do that?
Flags: needinfo?(epinal99-bugzilla2)

Comment 5

4 years ago
Instead of downgrading, you can uninstall Aurora and reinstall it again:
https://www.mozilla.org/en-US/firefox/channel/#developer

Of course, don't delete the profile when uninstalling Aurora (if you want to keep your private data).
Maybe remove manually the install folder too.
Flags: needinfo?(epinal99-bugzilla2)
(Reporter)

Comment 6

4 years ago
I deleted Firefox Developer Edition, and reinstalled it, and now it's back to normal.

Problem Solved!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.