[RFE] support resumation of downloads

VERIFIED DUPLICATE of bug 107552

Status

()

Core
Networking
--
enhancement
VERIFIED DUPLICATE of bug 107552
17 years ago
16 years ago

People

(Reporter: John Levon, Assigned: neeti)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.6+) Gecko/20011123
BuildID:    

I often download 3 or 4 meg of a file then my internet connection
goes down. I would love for mozilla to support resume (both ftp
and http) !

Reproducible: Always
Steps to Reproduce:
1. download file
2. stop.
3. download again

Actual Results:  It replaced the file.

Expected Results:  It should have continued downloading the file from last point.

Comment 1

17 years ago
resume ftp: bug 107552
resume http: bug 98288

*** This bug has been marked as a duplicate of 107552 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

17 years ago
R.K., do these bugs include resuming a download from a previous mozilla session ?
just like wget --continue can carry on working from a part file. 
I knew about one of the bugs you listed, but that seems concerned with
pause/resume, which is slightly different.

In particular I want to see the dialog "Replace file y/n ?" also have a "resume
?" option, if you see what I mean.
We have a bug about a download manager.
With this download manager you should be able to resuming a download from a
previous mozilla session.


Download manager bug 102477
see also bug 18004 ([RFE] general issues w/ resumable downloads (ftp+http))

(Reporter)

Comment 4

16 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.