If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

mozilla.org front page doesn't lead to links for submitting bugs or patches

REOPENED
Unassigned

Status

www.mozilla.org
Pages & Content
--
minor
REOPENED
3 years ago
a year ago

People

(Reporter: fantasai, Unassigned)

Tracking

Production

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kb=1640850])

(Reporter)

Description

3 years ago
Overview: 

  As someone who got involved as volunteer in QA and then coding, I'm
  a little concerned about how welcoming Mozilla is to people such as
  me these days. AFAICT, the path I took to entering Mozilla is closed,
  which I find distressing.

Steps to Reproduce:

  1. Go to http://mozilla.org/
  2. Try to report a bug or submit a patch.

(... no, really, please do try to reproduce this ... I'll wait ... :)

Expected Results:

  Found bug reporting system, possibly some guidance on how to use it well.

Actual Results:

  Presented with a form in which I can send an enquiry, with my
  name and email address and a brief message, in order to "get
  involved" in testing.

  (Presumably the person on the other end, if there is one, would
  send me a link to Bugzilla if I beg nicely, but at this point
  I would give up because I don't want to receive an automated
  reply, to register as a volunteer, to sign up for a mailing list,
  or to talk to nice people about my engagement prospects. I just
  want to report a bug or submit a patch.)
Whiteboard: [kb=1640850]

Updated

3 years ago
Severity: blocker → enhancement
We're going to update the "Contribute to this page" link in the footer, which would satisfy this use case. 

It will point to https://wiki.mozilla.org/Webdev/GetInvolved/mozilla.org
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1144949
(Reporter)

Comment 2

3 years ago
Reopening, because bug 1144949 is a completely separate issue.

Let me clarify, since I was perhaps a little unclear. Since you work on the website, of course you'd be thinking about making it easier to find out how to bugs on the website! But I worked on Gecko, and it is really not easy to find out how to file bugs on Gecko (or anything else, for that matter).

> Steps to Reproduce:
> 
>   1. Go to http://mozilla.org/
>   2. Try to report a bug or submit a patch TO FIREFOX/GECKO/THUNDERBIRD/ETC.

Upgrading severity because while people can get around this problem by running a Google search for "Mozilla bug report", one of the major purposes of mozilla.org is (or perhaps was-and-is-no-longer?) to guide contributors to the right places in the project, and in the current design, that's not happening in any reasonably sane or welcoming way for code and QA contributions.
Severity: enhancement → blocker
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
CC'ing :jbertsch for some input here.

Making it easy for people to report bugs is indeed important, and maybe this should be some part of the mozilla.org homepage past where it is currently. I think we do also need to consider the broad range of visitors who hit the mozilla.org home page. Many are likely not very technically savvy, and I think would likely find the existing SUMO "Need help?" link more helpful and relevant. 

Perhaps a simple "Report a bug" link in the footer, which goes to the bugzilla main page (https://bugzilla.mozilla.org/) would be a good middle ground. There are further links there on how & where to report bugs correctly.

Also, lowering the severity. While I appreciate you feel this is very important, in the grand scheme of really critical bugs, I don't think we need to make this stand out in bold red for everyone who sees it :)
Severity: blocker → minor
Thanks, Alex.

As we iterate on www.mozilla.org navigation and the footer content over this coming summer, we can consider adding Report a Bug to the footer.  As you mentioned, the audience to the homepage is broad, with the vast majority of folks looking to download Firefox.  And mart3ll looks like I've killed a kitten every time I suggest adding to the footer :)

fantasai:  Hope you are doing well!  You and I chatted a few times up on 7 in SF back in the day.  We can leave this bug open or we can close it, but MDN gets great placement for the searches "submit a patch to Mozilla" or "submit a patch to Firefox" and the search for "report a firefox bug" works pretty well too, and therefore I don't see prioritizing this link in the short term.

I'll ask Mike to add links to the MDN (https://wiki.mozilla.org/Webdev/GetInvolved/mozilla.org and https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines) documentation to the Webdev wiki at our Contribute to this Site link for folks who want to contribute to Firefox and not our website.
I added links to bug writing guidelines and QA homepage here:

https://wiki.mozilla.org/Webdev/GetInvolved/mozilla.org#Getting_Started
(Reporter)

Comment 6

2 years ago
The bug is still open. I shouldn't have to run a Google search to find something like this from the *main front page of an open source project*. You put SO MUCH EFFORT into making it so easy for me to find VIDEOS of how cool it would be to work on Mozilla [1], and a lovely forum to discuss how cool it would be to work on Mozilla with other people who also like to watch videos about contributing to Mozilla but there isn't a single findable link to Bugzilla or MDN anywhere for people to *actually* contribute to Mozilla.

Why are we spending so much effort into convincing people to do something, but none in directing them to resources for actually doing it? I really don't understand.

[1] https://www.mozilla.org/en-US/contribute/task/joy-of-coding/?v=2

If I'm not making sense, why don't we start at the top: what are the goals for https://www.mozilla.org/en-US/contribute/ ? Cuz if it's "show off how cool Mozilla is" maybe we're succeeding but if it's "guide potential volunteers to contribute" we're failing hard, at least as far as any technical contributions are concerned.
(Reporter)

Updated

a year ago
Duplicate of this bug: 1275323
You need to log in before you can comment on or make changes to this bug.