object-fit and object-position should apply to xul:image and other XUL replaced elements

RESOLVED DUPLICATE of bug 1094609

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 1094609
3 years ago
3 years ago

People

(Reporter: Jeremy Morton, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
The CSS3 spec for object-fit is here:
http://dev.w3.org/csswg/css-images-3/#the-object-fit

This property is supposed to apply to all "replaced elements".  Surely xul:image is a replaced element.  It is replaced by (potentially) a raster image, just as an HTML <img> is.  Therefore it should be supported by these CSS properties.

Bug #624647 claimed to implement these CSS properties but it has not done so for XUL elements.  They need to be implemented for XUL elements.
(Reporter)

Updated

3 years ago
Blocks: 624647
Thanks for filing. Bug 1094609 covers this already -- duping to that bug.

(For background: as noted in that bug, <xul:image> and <svg:image> use a different not-specific-to-replaced-elements image-drawing codepath, which is why they weren't fixed by the patches in bug 624647.)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1094609
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.