No video only audio on MP4 playback on the Lenovo S650 (MediaTek)

RESOLVED DUPLICATE of bug 1131793

Status

()

Firefox for Android
Audio/Video
RESOLVED DUPLICATE of bug 1131793
3 years ago
2 years ago

People

(Reporter: florin arjocu, Unassigned)

Tracking

36 Branch
Other
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Android; Mobile; rv:36.0) Gecko/36.0 Firefox/36.0
Build ID: 20150120155239

Steps to reproduce:

Trying to view this movie in Html5 format: http://superweb.rol.ro/video/b86626fb6e2d0c8719a53622305632e3.html


Actual results:

Firefox and Firefox beta for Android Should have played nicely as it does in Android browser or Chrome.


Expected results:

Got sound and black screen. I use a Lenovo S650 smartphone.
Suspect this as a chipset (MediaTek) issue, can not reproduce on my Galaxy S5/Nexus 6. Soft-dep bug 1100126?
Depends on: 1100126
Does the same thing happen on my media test page? http://people.mozilla.org/~atrain/mobile/tests/media.html
Flags: needinfo?(florin.arjocu)
Summary: Html5 movie black screen → No video only audio on MP4 playback on the Lenovo S650 (MediaTek)
(Reporter)

Comment 3

3 years ago
Just tried it on the phone and most of them do not work (only 2 work, first and aac audio). These need a fix: h/264/mp4, mp3, mp4 h.264 high profile  (avc1.64001e), mp4 h.264 baseline profile (avc1.42001e). Sound works on movies, but the video part does not. Click-ing the page anywhere or scrolling makes the movie canvas flicker. Tried both on Firefox Beta for Android and Firefox for Android.
Flags: needinfo?(florin.arjocu)
(Reporter)

Comment 4

3 years ago
Created attachment 8555687 [details]
2015-01-28_0825009.mp4 screen record html5 bug on firefox beta for android

This is how it works on my Firefox Beta for Android. It is black (only on non-beta Firefox flickers). Mp3 is not working and none of the h.264, either.
(Reporter)

Comment 5

3 years ago
Created attachment 8555695 [details]
2015-01-28_0825009.mp4 screen record html5 bug on firefox beta for android 2

Something happened with my attachment, so I upload it again, this time from computer.
We don't need multiple bugs reported.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1131793
You need to log in before you can comment on or make changes to this bug.