The favicon is not transparent on mozilla.org

RESOLVED FIXED

Status

www.mozilla.org
General
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Amjad M, Assigned: agibson)

Tracking

Production
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kb=1643351])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
The favicon (background)-https://github.com/mozilla/bedrock/tree/master/media/img/favicon- for mozilla.org is not transparent.
(Assignee)

Comment 1

3 years ago
Thanks for the report.

The regular mozilla.org favicon is here: https://github.com/mozilla/bedrock/blob/master/media/img/favicon.ico

I believe the one you linked to in the description is a larger version, which is used as a home screen icon on mobile devices such as Firefox OS and Android. If I understand correctly, the white background might be intentional here to make sure contrast is sufficient against darker backgrounds.

Can you please give some information as to why you think this should be a bug, and where there might be an issue with the current format? It would be good to understand the context here for why you think it would be better serving a transparent background.

Thanks
Flags: needinfo?(amjadm61)
(Reporter)

Comment 2

3 years ago
Created attachment 8555176 [details]
screenshot.JPG

Thanks Alex for your comment.

Plz check the screenshot that I attached along with this comment.
Did you see the difference between the two icons that I rounded with red color?

Yes. I just meant only that, It would be great if we can use the transparent icon.
The transparent icon looks like more better than the icon with white background.

I just shared my thought. What do you think? Is it better or not?
Flags: needinfo?(amjadm61)
(Assignee)

Comment 3

3 years ago
Many thanks for confirming, Amjad!
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [kb=1643351]
(Assignee)

Updated

3 years ago
Assignee: nobody → agibson
Status: NEW → ASSIGNED
(Assignee)

Comment 4

3 years ago
Created attachment 8555803 [details] [review]
GitHub pull request

Comment 5

3 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/2c2491285c56e059e8907a320a2e4b179f881afb
[fix bug 1125623] The favicon is not transparent on mozilla.org

https://github.com/mozilla/bedrock/commit/88cbc1686495979bf115e3db4290ceac8c6aebbb
Merge pull request #2691 from alexgibson/bug-1125623-favicon-not-transparent

[fix bug 1125623] The favicon is not transparent on mozilla.org

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

3 years ago
Hi Alex,
I couldn't find the changes you made in the production (mozilla.org) sites. Your change has affected only in the staging site (www.allizom.org).
The mozilla.org icon is still in white background.
(Assignee)

Comment 7

3 years ago
(In reply to Amjad M from comment #6)
> Hi Alex,
> I couldn't find the changes you made in the production (mozilla.org) sites.
> Your change has affected only in the staging site (www.allizom.org).
> The mozilla.org icon is still in white background.

Hi Amjed - this change has not yet made it to production, and is currently as far as our staging environment. This is why you currently only see the change on www.allizom.org. Once we do our next scheduled push to production, this change will go live. Thanks for checking!
You need to log in before you can comment on or make changes to this bug.