Closed Bug 1125639 Opened 5 years ago Closed 5 years ago

YouTube HTML5 videos are choppy in Windows 10

Categories

(Core :: Audio/Video, defect)

36 Branch
x86_64
Windows 10
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: koppah, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150122214638

Steps to reproduce:

Play a video on YouTube in the HTML5 player on Windows 10 with an Intel HD GPU


Actual results:

Video is choppy in Firefox, but works fine in Chrome and IE.


Expected results:

Video playback is smooth
    adapterDescription: Intel(R) HD Graphics Family
    adapterDescription2:
    adapterDeviceID: 0x0a16
    adapterDeviceID2:
    adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32
    adapterDrivers2:
    adapterRAM: Unknown
    adapterRAM2:
    adapterSubsysID: 00051414
    adapterSubsysID2:
    adapterVendorID: 0x8086
    adapterVendorID2:
    direct2DEnabled: True
    directWriteEnabled: True
    directWriteVersion: 10.0.9926.0
    driverDate: 1-5-2015
    driverDate2:
    driverVersion: 10.18.15.4079
    driverVersion2:
    info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
    isGPU2Active: False
    numAcceleratedWindows: 1
    numTotalWindows: 1
    webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D9Ex vs_3_0 ps_3_0)
    windowLayerManagerRemote: True
    windowLayerManagerType: Direct3D 11
Blocks: windows-10
OS: Windows NT → Windows 10
I can't reproduce this bug. Can you try using a blank profile ? (Run Firefox with the -p flag).
Component: Untriaged → Video/Audio
Product: Firefox → Core
Flags: needinfo?(koppah)
I just tried on a blank profile - same problem. Can I capture a trace to help you debug?
Flags: needinfo?(koppah) → needinfo?(ntim007)
I don't work on this domain, but it should help developers working on that domain.

I'm just checking if this issue is specific to your profile/configuration, since I use Windows 10 myself, and I don't run into this issue. Were you able to reproduce this on your previous OSes ?
Flags: needinfo?(ntim007)
Negative - it's specific to the new build of Windows 10 (Tech Preview 2 - Build 9926). I don't recall it being an issue before. Does not occur on the same build with a different GPU. I have a Surface Pro 3, and it might simply be the video drivers. Let's leave it as  'Not Repro' for now and I'll chase it up with Microsoft.
There's a confirmation by Microsoft.

> we’re seeing reports of YouTube videos choppy in Firefox 36 on our latest Windows 10 build publicly released yesterday (March 19, 2015).
Status: UNCONFIRMED → NEW
Ever confirmed: true
I had the same problem start happening on the previous build (9926, as reported above) and persist on the one just released (10041) but an updated Intel graphics driver was pushed over Windows Update the day after 10041 was released and now the problem is fixed for me.
Agreed - resolved for my by upgrade to 10041 and a new Intel driver.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.