Closed Bug 1125686 Opened 5 years ago Closed 4 years ago

loses network connectivity, hangs on shutdown, can't kill process; leading to crashes or "profile in use" / "profile is broken or missing" on subsequent startup

Categories

(Firefox :: Untriaged, defect)

36 Branch
x86_64
Windows 8
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: habanero01, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 20150108202552

Steps to reproduce:

I was browsing, after a time with the browser in background I was going to open an url and it never loads.


Actual results:

I closed Firefox and started again but it showed me an alert with a message that says something like your Firefox can not start because it is still in use .. and 2 buttons: Close Firefox and Cancel. I clicked Close Firefox and it showed me another message, something like: Profile can not be opened, it is broken or missing. I created a new profile but minutes later, it happened again. Also happened with Firefox Developer Edition after I updated to 37.0a1.


Expected results:

It was supposed to open. I have restarted my system twice. Now I installed 35 with a clean profile, old profile files still there. Now everything seems okay.
Firefox process remains in the task manager and I can not Finish the process.
Thanks for taking the time to report this!
Please follow the steps on http://support.mozilla.com/kb/Firefox%20crashes and report back here. Thanks!
Flags: needinfo?(habanero01)
Having the same issue with regular FF and Nightly, won't even start in safe mode.

bp-05243ddb-54bc-4473-ae61-d5b072150303	03/03/2015	22:53
bp-bd6f5282-ce22-4d8f-8f2f-8c81b2150303	03/03/2015	22:52
bp-1d98adf9-0868-44e5-8204-ef3132150303	03/03/2015	22:49
bp-e0f11f2a-7150-4253-a021-2c63a2150303	03/03/2015	22:36
bp-7f7c51cd-8d41-47e6-ad21-3582b2150303	03/03/2015	22:36
bp-a9675d4a-be78-45ee-a257-d36852150302	03/02/2015	21:45
bp-1ec7b2c9-e7a9-4d90-a27b-f1ba92150302	03/02/2015	21:45
bp-5c2760fd-b6e3-455e-87a3-d90962150301	03/01/2015	17:55
bp-fcca2f66-9362-40e0-bedb-90c142150301	03/01/2015	14:29
bp-f4f84364-75e5-49c1-8a2d-75df62150228	02/28/2015	20:33
3f14f3f2-5323-4698-b358-4f8b7fdccea6	02/27/2015	20:54
1d2a7c25-e00e-42e6-b9d2-bd55d28ad540	02/26/2015	23:39
64be955e-cb16-447e-a5cc-b30c675446f4	02/25/2015	14:03
b89e451a-074b-4a85-b82f-4a41bb73cb75	02/24/2015	16:07
c73e6fe4-abbc-4646-b6e9-c8fc8a647146	02/24/2015	13:05
bp-625e7685-c2ed-473e-8ad2-fb29d2150223	02/23/2015	20:02
bp-87b6d5d3-dc48-4180-ad55-d285a2150223	02/23/2015	19:59
Also, creating a new profile only works for a while, I've burned through at least 5 while reporting this issue.
I experimented the same again. I noticed, When I go to TaskManager, and try to end process it ends, but in the Tab Details of the Task Manager, still a firefox.exe and can't end the proccess. That is why I can't start firefox again until I restart the system. I am using a Firefox Portable and it does not happened again. I stoped having that problem for a while (more than a month) but it just back yesterday
Flags: needinfo?(habanero01)
I also clear the install folder, the Profile Folder (the entire Mozilla Firefox folder from AppData) uninstalled it and reinstaled it again and it continue happening.
Jaagup: your crash reports point to bug 1124880 (see bug 1124880 comment 15). That bug says the network changes (cable unplugged, wifi changed) can cause this and it seems you can try the most recent nightly (with a clean profile) to see if the patch in that bug fixes the problem for you.

Erick: I believe if you wait for a minute after you see the hang on shutdown, the crash reporter will kick in and let you send a report to mozilla. If not, try this https://developer.mozilla.org/en-US/docs/How_to_Report_a_Hung_Firefox

Please post the crash ID to be sure, as your issue may be also related to 1124880.
Flags: needinfo?(habanero01)
Summary: Firefox crashes and says it is still in use and profile is broken or missing → loses network connectivity, hangs on shutdown, leading to crashes or "profile in use" / "profile is broken or missing" on subsequent startup
(I CCed everyone I pointed to this bug here, sorry if it was unwanted.)

According to bug 1124880 comment 39 adding a Windows firewall rule or upgrading to Firefox 37 (soon to be released) might help with this problem. Please let me know if it does.

Also linking a forum thread on this topic: http://forums.mozillazine.org/viewtopic.php?f=38&t=2916383
Summary: loses network connectivity, hangs on shutdown, leading to crashes or "profile in use" / "profile is broken or missing" on subsequent startup → loses network connectivity, hangs on shutdown, can't kill process; leading to crashes or "profile in use" / "profile is broken or missing" on subsequent startup
I tested with FF38 and seems to be fixed now.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Confirmed, I start using non-portable and 38 works fine. I will update in case of change.
Flags: needinfo?(habanero01)
 Based on comment #10 and comment #9 I will mark this bug as resolved.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.