Closed Bug 1125716 Opened 5 years ago Closed 5 years ago

[Stingray] Browser context menu should listen key up event

Categories

(Firefox OS Graveyard :: Gaia, defect)

x86
Gonk (Firefox OS)
defect
Not set

Tracking

(feature-b2g:2.5+)

RESOLVED DUPLICATE of bug 1164353
feature-b2g 2.5+

People

(Reporter: suchiu, Assigned: yifan)

References

Details

(Whiteboard: [ft:conndevices])

Browser context menu is listening key down event right now while home app is listening key up event. So when we want to pin a app to home page and do a click, both context menu and home app will trigger the corresponding handler.
<button> element in browser context menu is listening 'click' event, however, for <button> element, click event is also triggered by keydown event in nature.
Blocks: 1190158
feature-b2g: --- → 2.5+
Assignee: suchiu → yliao
Status: NEW → ASSIGNED
Hi YiFan,
Do we still need this bug in 2.5?
Flags: needinfo?(yliao)
Whiteboard: [ft:conndevices]
Blocks: 1198099
Fixed in bug 1164353.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Flags: needinfo?(yliao)
Resolution: --- → DUPLICATE
Duplicate of bug: 1164353
You need to log in before you can comment on or make changes to this bug.