[Flame][Bluetooth]Music can't be played and stopped remotely via bluetooth headphone.

RESOLVED DUPLICATE of bug 1124760

Status

Firefox OS
Gaia::Music
--
major
RESOLVED DUPLICATE of bug 1124760
3 years ago
3 years ago

People

(Reporter: Norry.L.F(Leave from Mozilla), Unassigned)

Tracking

({regression, smoketest})

unspecified
ARM
Gonk (Firefox OS)
regression, smoketest

Firefox Tracking Flags

(b2g-v2.1 unaffected, b2g-v2.2 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8554453 [details]
video.mp4

[1.Description]:
[Flame][v2.2][Bluetooth]Music can't be played and stopped remotely via bluetooth headset ,if you long press foward via BT HS,device's stop function will fail.
Found time:16:42
Attachment:video.mp4 & logcat_1642.txt
BT HS:sony mw600

[2.Testing Steps]: 
1. Enable Bluetooth and connect to a bluetooth headphone. 
2. Go to Music app. 
3. Select a music to play.
4. Press BT HS' Play/Forward/Previous button.

Note:
1.Device can  recognition fast forward/previous command.
2.Stop function will failure after excute fast forward operation via BT HS.

[3.Expected Result]: 
4. Music App can be control via BT HS.

[4.Actual Result]: 
4.Divice is no responce.

[5.Reproduction build]: 
Flame 2.1 build:
Gaia-Rev        54d92cc0755e5102223276ab23063b5eee74b514
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/522d6c980917
Build-ID        20150125001312
Version         34.0
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150125.035903
FW-Date         Sun Jan 25 03:59:13 EST 2015
Bootloader      L1TC000118D0

Flame 2.2 build:
Gaia-Rev        0518f4581a0925c0b703d730ef289ab15cbd1216
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c6aa604a7967
Build-ID        20150125002503
Version         37.0a2
Device-Name     flame
FW-Release      4.4.2
FW-Incremental  eng.cltbld.20150125.035924
FW-Date         Sun Jan 25 03:59:36 EST 2015
Bootloader      L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
9346
(Reporter)

Comment 1

3 years ago
Created attachment 8554454 [details]
logcat_1642.txt

Comment 2

3 years ago
Bug 1103254 ?
QA Whiteboard: [COM=Bluetooth]
Keywords: regression, smoketest

Comment 3

3 years ago
(In reply to Dominic Kuo [:dkuo] from comment #2)
> Bug 1103254 ?

But, the v2.2 has used the correct path of the player view file, right? :)
--- -- - --- -- - v2.2 --- -- - --- -- -
 if (typeof PlayerView === 'undefined') {
LazyLoader.load('js/ui/views/player_view.js', function() {
PlayerView.init();
PlayerView.setOptions(App.playerSettings);
Set 2.2? for regression.

*** Issue
FF, RWD, Pause, play not working. 
Music streaming is okay.

*** Version reproducible
Serial: e477d8e3 (State: device)
Build ID               20150126002536
Gaia Revision          0518f4581a0925c0b703d730ef289ab15cbd1216
Gaia Date              2015-01-24 20:56:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/c6
aa604a7967
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150126.042138
Firmware Date          Mon Jan 26 04:21:49 EST 2015
Bootloader             L1TC000118D0
blocking-b2g: --- → 2.2?
Can you do the following things?
adb shell cat /init.bluetooth.rc
Flags: needinfo?(ericchang591)
The fix had already in 
Bug 1124760: Add net_bt_stack and bluetooth permission for enabling AVRCP in bluetoothd.

And you need to flash boot.img. The configuration shall be in device and path is /init.bluetooth.rc

Comment 7

3 years ago
This would be a duplicated bug for bug 1124760. That bug is waiting for approval to uplift onto v2.2.
Cancel ni
Flags: needinfo?(ericchang591)
Yes. We're waiting for approval now in v2.2.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1124760

Updated

3 years ago
blocking-b2g: 2.2? → ---

Updated

3 years ago
QA Whiteboard: [COM=Bluetooth]
You need to log in before you can comment on or make changes to this bug.