firefox, proxy => bad webpage loading

RESOLVED DUPLICATE of bug 1123324

Status

()

Core
Networking: HTTP
RESOLVED DUPLICATE of bug 1123324
3 years ago
3 years ago

People

(Reporter: promeneur, Unassigned)

Tracking

35 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:35.0) Gecko/20100101 Firefox/35.0
Build ID: 2015010900

Steps to reproduce:

OS : opensuse 13.1 x86_64 
Proxy : privoxy 3.0.22

since firefox 35

For every site to load a page completly i must reload the page (www.lemonde.fr, www.liberation.fr, bugzilla.mozilla.fr etc.)

sometime firefox displays a text file , sometime a webpage without photos

for every site to get an answer to a request i must resend the request (maps.google.com, viamichelin.fr, open.mapquest.fr etc.)

very frequently firefox says it does not find the proxy . i must reload the page .





Expected results:

firefox load any webpage completely without reloading
(Reporter)

Comment 1

3 years ago
Created attachment 8554520 [details]
lemonde_bad_loading.png

see an exemple of text page of www.lemonde.fr
(Reporter)

Comment 2

3 years ago
Created attachment 8554523 [details]
lemonde_reloaded.png

see the reloaded webpage of www.lemonde.fr
(Reporter)

Comment 3

3 years ago
Created attachment 8554524 [details]
liberation_bad_loading.png

see the web page of www.liberation.fr without photos
(Reporter)

Comment 4

3 years ago
Created attachment 8554525 [details]
liberation_reloaded.png

see the reloaded webpage of www.liberation.fr
Is your proxy working in a different browser without issues ?
Do you know if it worked in previous verions of Firefox with the same proxy ?
Component: Untriaged → Networking: HTTP
Product: Firefox → Core
(Reporter)

Comment 6

3 years ago
>> Is your proxy working in a different browser without issues ?

with chromium no problem .

>> Do you know if it worked in previous verions of Firefox with the same proxy ?

no pb with previous version
Can you send as a log:

https://developer.mozilla.org/en-US/docs/Mozilla/Debugging/HTTP_logging

thanks.
Flags: needinfo?(epistemepromeneur)
looking at the log from bug 1112365 (they sounds like similar issue), I will mark this as duplicate of bug 1123324.

A test for this bug would be disabling ipv6, in about:config setting network.dns.disableIPv6 to true.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(epistemepromeneur)
Resolution: --- → DUPLICATE
Duplicate of bug: 1123324
(Reporter)

Comment 9

3 years ago
i confirm i use ipv6 and ipv4 .

privoxy uses ipv6 then firefox is obliged to use ipv6
You need to log in before you can comment on or make changes to this bug.