Closed Bug 1125822 Opened 10 years ago Closed 6 years ago

Browser Console throws exception trying to print output when a page runs console.dir()

Categories

(DevTools :: Console, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(firefox36 affected, firefox38 affected)

RESOLVED WORKSFORME
Tracking Status
firefox36 --- affected
firefox38 --- affected

People

(Reporter: TeoVermesan, Unassigned)

References

()

Details

Attachments

(1 file)

Reproducible on the latest Nightly (BuildID: 20150126030202): 
Mozilla/5.0 (X11; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0

Steps to reproduce:
1. Go to https://etherpad.mozilla.org/Fx36b3
2. Open in new tab the link from line 82

Issue: 
The following exception is thrown in the browser console:
[Exception... "Component returned failure code: 0x80004002 (NS_NOINTERFACE) [nsIWebProgress.DOMWindow]"  nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "JS frame :: chrome://browser/content/browser.js :: TabsProgressListener.onStateChange :: line 13700"  data: no]
I was able to reproduce the issue on Firefox 35.0 build 3, Firefox 36 beta 3 and latest Nightly 38 (2015-01-26).
I can reproduce on 44, but not on Nightly. Are you still seeing this on Nightly?
Component: General → Tabbed Browser
Flags: needinfo?(teodora.vermesan)
This is what I get in the Browser Console:

https://pastebin.mozilla.org/8858205 in VariablesViewController.jsm:334:0
Flags: needinfo?(teodora.vermesan)
(In reply to Teodora Vermesan (:TeoVermesan) from comment #3)
> This is what I get in the Browser Console:
> 
> https://pastebin.mozilla.org/8858205 in VariablesViewController.jsm:334:0

This error is generated by the devtools. In your steps to reproduce, the devtools aren't opened in any way. Can you retry your STR on a clean profile and/or restate your STR so they include whatever you're doing with devtools?
Flags: needinfo?(teodora.vermesan)
So: 
1. installed 36b3 and had Browser Console opened
Results:
- [Exception... "Component returned failure code: 0x80004002 (NS_NOINTERFACE) [nsIWebProgress.DOMWindow]"  nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "JS frame :: chrome://browser/content/browser.js :: TabsProgressListener.onStateChange :: line 15551"  data: no]
2. installed 44.0 build 3 
2.1 Had the browser console opened
Results:
- [Exception... "Component returned failure code: 0x80004002 (NS_NOINTERFACE) [nsIWebProgress.DOMWindow]"  nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "JS frame :: chrome://browser/content/browser.js :: TabsProgressListener.onStateChange :: line 15551"  data: no]
- https://pastebin.mozilla.org/8858205 

2.2 Had the browser console closed while performing the steps and only after that opened it
Results:
- only [Exception... "Component returned failure code: 0x80004002 (NS_NOINTERFACE) [nsIWebProgress.DOMWindow]"  nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "JS frame :: chrome://browser/content/browser.js :: TabsProgressListener.onStateChange :: line 15551"  data: no]

3. installed latest Nightly
3.1 Had the browser console opened
- https://pastebin.mozilla.org/8858205
3.2 Had the browser console closed while performing the steps and only after that opened it
- nothing in browser console
Flags: needinfo?(teodora.vermesan)
From the pastebin:

Date: Mon Feb 01 2016 17:34:43 GMT+0200 (EET)
Full Message: TypeError: invalid 'in' operand aGrip
Full Stack: VariablesViewController.prototype._populateFromObject@resource://devtools/client/shared/widgets/VariablesViewController.jsm:334:1
VariablesViewController.prototype.populate@resource://devtools/client/shared/widgets/VariablesViewController.jsm:572:7
VariablesViewController.prototype.setSingleVariable@resource://devtools/client/shared/widgets/VariablesViewController.jsm:706:19
JSTerm.prototype._updateVariablesView@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/client/webconsole/webconsole.js:3519:34
JSTerm.prototype.openVariablesView/onContainerReady@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/client/webconsole/webconsole.js:3336:7
Handler.prototype.process@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:937:23
this.PromiseWalker.walkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:816:7
Promise*this.PromiseWalker.scheduleWalkerLoop@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:747:11
this.PromiseWalker.schedulePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:779:7
this.PromiseWalker.completePromise@resource://gre/modules/Promise.jsm -> resource://gre/modules/Promise-backend.js:714:7
onIframeLoad@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/client/webconsole/webconsole.js:3356:9
EventListener.handleEvent*JSTerm.prototype.openVariablesView@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/client/webconsole/webconsole.js:3353:7
WebConsoleFrame.prototype.createMessageNode@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/client/webconsole/webconsole.js:2431:7
WebConsoleFrame.prototype.logConsoleAPIMessage@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/client/webconsole/webconsole.js:1334:14
WebConsoleFrame.prototype._outputMessageFromQueue@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/client/webconsole/webconsole.js:2111:16
WebConsoleFrame.prototype._flushMessageQueue@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/client/webconsole/webconsole.js:2003:20 


Patrick, can you redirect this to someone who can figure out what's going on here?
Component: Tabbed Browser → Developer Tools: Console
Flags: needinfo?(pbrosset)
Summary: Opening a short link in new tab throws an exception → Opening a short link in new tab throws an exception if the browser console is open while opening the link
Flags: needinfo?(pbrosset) → needinfo?(bgrinstead)
OK so I'm opening http://bzfd.it/1zCVQ51.  Trying to log out aGrip here: https://dxr.mozilla.org/mozilla-central/source/devtools/client/shared/widgets/VariablesViewController.jsm#334 and I get <unavailable>.

This all seems to stem from a failed call to console.dir at line 2 of https://s3-ak.buzzfed.com/static/js/General_concat_header.js?v=1454350084 (a minified file)
Version: 36 Branch → Trunk
Interesting though that the dir works in the page's web console
Flags: needinfo?(bgrinstead)
Summary: Opening a short link in new tab throws an exception if the browser console is open while opening the link → Browser Console throws exception trying to print output when a page runs console.dir()
Product: Firefox → DevTools
All the URLs from the different comments are either not available anymore or doesn't have a console.dir.
Since the file where the error ocured is not used by the console anymore, I think we can safely close this bug.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: